Guest

Preview Tool

Cisco Bug: CSCzi09700 - Message generated by the Test Message dialog is incorrect for a So...

Last Modified

Feb 06, 2014

Products (2)

  • Cisco ACE XML Gateways
  • Cisco ACE XML Gateway

Known Affected Releases

5.0

Description (partial)

Symptom:
Message generated by AXG's test message dialog for SOAP services that are schema based, does not create argument type attributes in the argument elements. Some vendors like WebSphere require this element to be present.
Conditions:
Here is a sample message created by the test message dialog:
<?xml version="1.0" encoding="UTF-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:reac="http://tempuri.org/reactivity.IBMTestObject">
  <soap:Body>
    <reac:echoString>
      <s>some string argument</s>
    </reac:echoString>
  </soap:Body>
</soap:Envelope>

Notice that <CmdArg><s>some string argument </s></CmdArg> does not have a xsi:type attribute. Most vendors do not require this, since normally the back-end has published or owns a copy of  the Schema Based WSDL that is being called and they are aware of the type of each argument.
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.