Guest

Preview Tool

Cisco Bug: CSCvv46773 - access-session control-direction in does not take effect with spanning-tree portfast default

Last Modified

Oct 08, 2020

Products (1)

  • Cisco Catalyst 9400 Series Switches

Known Affected Releases

16.12.4

Description (partial)

Symptom:
When access-session control-direction is configured on an interface in combination with access-session closed, the command does not take any effect on egress traffic if spanning-tree portfast is not statically added to the interface either manually or via a template. Although the spanning-tree portfast default has been configured globally and the interface is operational in access mode, access-session control-direction in still needs the command spanning-tree portfast configured on the interface for it to take effect.

147USERS#sh derived interface gi2/0/10
Building configuration...

Derived configuration : 559 bytes
!
interface GigabitEthernet2/0/10
 switchport access vlan 2
 switchport mode access
 device-tracking attach-policy DT-PORT
 ipv6 nd raguard
 authentication periodic
 authentication timer reauthenticate server
 access-session control-direction in
 access-session closed
 access-session port-control auto
 mab
 dot1x pae authenticator
 dot1x timeout tx-period 4
 storm-control broadcast level 5.00
 storm-control multicast level 5.00
 storm-control action shutdown
 service-policy type control subscriber ZTN_Policy_v2.4
 service-policy input mark-traffic
end
!
147USERS#sh run | include spanning-tree
spanning-tree mode rapid-pvst
spanning-tree portfast default
spanning-tree extend system-id
!
147USERS#show spanning-tree interface gi2/0/10
no spanning tree info available for GigabitEthernet2/0/10


Conditions:
spanning-tree portfast default applied globally instead of being applied manually on the interfaces
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.