Guest

Preview Tool

Cisco Bug: CSCvv14451 - 2960X Member Switches Lose Device Classifier, Breaking Auto Smart Ports (ASP)

Last Modified

Sep 02, 2020

Products (1)

  • Cisco Catalyst 2960-X Series Switches

Known Affected Releases

15.2(7.1.67)E2

Description (partial)

Symptom:
End-devices (IP Phones, APs, etc) that connect to 2960X stack members that expect the auto-smart port feature to run and execute will not properly do so, resulting in the port failing to be programmed as expected.

As an example, this 2960X stack of 3 has a device connected to it and the following macro should be executed:

2960X#show switch
Switch/Stack Mac Address : 38ed.186e.af00
                                           H/W   Current
Switch#  Role   Mac Address     Priority Version  State
----------------------------------------------------------
 1       Member dca5.f491.3a80     15     4       Ready
 2       Member f09e.63e7.b500     1      4       Ready
*3       Master 38ed.186e.af00     1      4       Ready

macro auto mac-address-group TEST
 oui list 007C2D

macro auto execute TEST  {
 if [[ $LINKUP == YES ]]
  then  conf t
  interface $INTERFACE
  macro description $TRIGGER
  switchport voice vlan 420
  switchport mode access
  priority-queue out
  spanning-tree portfast
  spanning-tree bpduguard enable
  storm-control broadcast level 70.00
  storm-control action trap
  service-policy input QOS-General
  exit
 fi
 if [[ $LINKUP == NO ]]
  then conf t
  interface $INTERFACE
  no macro description
  switchport voice vlan 666
  switchport mode access
  no priority-queue out
  no spanning-tree portfast
  no spanning-tree bpduguard enable
  no storm-control broadcast level 70.00
  no storm-control action trap
  no service-policy input QOS-General
  exit
 fi
}

Upon a shut/no shut of the port where the device is connected to, the macro does not correctly execute even though the interface is up and the MAC is learnt on the port:

2960X(config)#int g1/0/3
2960X(config-if)#shut
Jan  3 00:17:50.659: %PARSER-5-CFGLOG_LOGGEDCMD: User:vty0  logged command:interface GigabitEthernet1/0/3
2960X(config-if)#shut
2960X(config-if)#no shut
2960X(config-if)#end

Jan  3 00:17:52.624: %PARSER-5-CFGLOG_LOGGEDCMD: User:vty0  logged command:shutdown
Jan  3 00:17:54.018: %PARSER-5-CFGLOG_LOGGEDCMD: User:vty0  logged command:no shutdown
Jan  3 00:17:54.459: %SYS-5-CONFIG_I: Configured from console by vty0 (127.0.0.4)
Jan  3 00:17:54.627: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/3, changed state to down
Jan  3 00:17:54.644: %PARSER-5-CFGLOG_LOGGEDCMD: User:tty17  logged command:interface GigabitEthernet1/0/3
Jan  3 00:17:54.682: %PARSER-5-CFGLOG_LOGGEDCMD: User:tty17  logged command:no macro description
Jan  3 00:17:54.752: %PARSER-5-CFGLOG_LOGGEDCMD: User:tty17  logged command:switchport voice vlan 666
Jan  3 00:17:54.766: %PARSER-5-CFGLOG_LOGGEDCMD: User:tty17  logged command:switchport mode access
Jan  3 00:17:54.836: %PARSER-5-CFGLOG_LOGGEDCMD: User:tty17  logged command:no priority-queue out
Jan  3 00:17:54.875: %PARSER-5-CFGLOG_LOGGEDCMD: User:tty17  logged command:no spanning-tree portfast
Jan  3 00:17:54.917: %PARSER-5-CFGLOG_LOGGEDCMD: User:tty17  logged command:no spanning-tree bpduguard
Jan  3 00:17:54.945: %PARSER-5-CFGLOG_LOGGEDCMD: User:tty17  logged command:no storm-control broadcast level
Jan  3 00:17:54.980: %PARSER-5-CFGLOG_LOGGEDCMD: User:tty17  logged command:no storm-control action trap
Jan  3 00:17:54.994: %PARSER-5-CFGLOG_LOGGEDCMD: User:tty17  logged command:no service-policy input QOS-General
Jan  3 00:17:54.994: %PARSER-5-CFGLOG_LOGGEDCMD: User:tty17  logged command:exit
Jan  3 00:17:54.997: %AUTOSMARTPORT-5-REMOVE: Device removed from interface GigabitEthernet1/0/3, executed TEST to remove the configuration
Jan  3 00:17:55.637: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/3, changed state to down
Jan  3 00:17:58.919: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/3, changed state to up
Jan  3 00:17:59.918: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/3, changed state to up



2960X#show mac add int g1/0/3
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
   1    007c.2daa.aabb    DYNAMIC     Gi1/0/3
Total Mac Addresses for this criterion: 1

2960X#show run int g1/0/3
Building configuration...

Current configuration : 89 bytes
!
interface GigabitEthernet1/0/3
 switchport mode access
 switchport voice vlan 666

You can also utilize this command (remote command all show run all | i classifier) to validate if the device classifier component has been enabled on all switches, if one or more switches are missing the output, there is a likelihood the issue will be experienced on that switch:

2960X#remote command all show run all | i classifier
Switch : 3 : (Master)
---------------------
device classifier

Switch : 1 :
------------
no device classifier <----- Problematic

Switch : 2 :
------------
device classifier

Conditions:
2960X stacks (not just a single switch) that utilizes the Auto Smart Port feature may experience this issue when devices that are plugged into the member switches of the stack fail to get enabled or loss the device classifier feature component.

Issue has been on 15.2(7)E2
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.