Guest

Preview Tool

Cisco Bug: CSCvv01226 - asn value out-of-range during Get operation in Cisco-IOS-XR-eigrp-oper.yang

Last Modified

Sep 16, 2020

Products (1)

  • Cisco ASR 9000 Series Aggregation Services Routers

Known Affected Releases

7.1.2.BASE

Description (partial)

Symptom:
Getting below error during Get operation from NSO:
show devices device <router-name> live-status eigrp-oper:eigrp | nomore
Error: 'devices device <router-name> live-status eigrp processes process <AS-Number> vrfs vrf <VRF-Name> afs af ipv4 ases as': "0" is out of range.
admin@ncs#

Conditions:
Issue is observed for EIGRP vrf configurations in below cases. 

1) When vrf defined under EIGRP is not configured globally.
RP/0/RP0/CPU0:Router#show run router eigrp 
router eigrp <AS-Number>
vrf <VRF-Name>
  address-family ipv4
   autonomous-system 2
   redistribute bgp 100
   interface GigabitEthernet0/1/5/2
    site-of-origin 3:4
   !
  !
!
RP/0/RP0/CPU0:Router#show run vrf 
% No such configuration item(s)

2) When "autonomous-system" is not configured for EIGRP VRF address-family.
RP/0/RP0/CPU0:Router#show run router eigrp 
router eigrp <AS-Number>
vrf <VRF-Name>
  address-family ipv4
   redistribute bgp 100
   interface GigabitEthernet0/1/5/2
    site-of-origin 3:4
   !
  !
!
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.