Guest

Preview Tool

Cisco Bug: CSCvu29574 - Cisco DNA Center - Cannot set port Authentication Template in SD-Access through API

Last Modified

Jun 04, 2020

Products (1)

  • Cisco DNA Center

Known Affected Releases

DNAC1.3.3.1

Description (partial)

Symptom:
In Cisco DNA Center, setting a port using the /intent/api/v1/business/sda/hostonboarding/user-device POST API does not correctly configure the provided authenticateTemplateName.

Note: The Authentication Template is set to Closed Authentication, hence all ports have the template prior to the following test:

1) before pushing config:

interface TenGigabitEthernet1/0/16
 switchport mode access
 device-tracking attach-policy IPDT_MAX_10
 dot1x timeout tx-period 7
 dot1x max-reauth-req 3
 source template DefaultWiredDot1xClosedAuth
 spanning-tree portfast
end

- after pushing with "authenticateTemplateName": "Open Authentication":

interface TenGigabitEthernet1/0/16
 switchport access vlan 1034
 switchport mode access
 switchport voice vlan 1036
 device-tracking attach-policy IPDT_MAX_10
 load-interval 30
 dot1x timeout tx-period 7
 dot1x max-reauth-req 3
 no macro auto processing
 source template DefaultWiredDot1xClosedAuth          <<<<<<< template not changed
 spanning-tree portfast
end

Conditions:
This was seen in Cisco DNA Center 1.3.3.1, but other versions may be affected

Related Community Discussions

How to automate Port Assignment?
Hello,  Is there any way to automate port assignment by python?  When I add new switches to the fabric I have to click on hundreds of ports and assign them to appropriate data ip pool, voice ip pool and authentication template. It isn't look like a convenient way (. Are there any other way? There is even no option to find the port by the name(.   I found this tool https://github.com/CiscoDevNet/dnacenter-host-onboarding but I not sure that it is compatible with fabric host onboarding to an approriate ...
Latest activity: Aug 22, 2020
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.