Guest

Preview Tool

Cisco Bug: CSCvu08927 - unable to poll CBqos of interfaces when type is used under interface service-policy command

Last Modified

Sep 28, 2020

Products (1)

  • Cisco IOS

Known Affected Releases

15.4(3)

Description (partial)

Symptom:
unable to poll CBqos of interfaces when type is used under interface service-policy command

Conditions:
when polling CBqos type we may not get the information.

Using the below document we can get Class-Based Quality of Service Details for an Interface Using SNMP
https://www.cisco.com/c/en/us/support/docs/ip/simple-network-management-protocol-snmp/119031-technote-router-00.html

Requirements
Cisco recommends that you have:

-- Net-SNMP, or any similar command line based utility, running on a UNIX based operating system, for polling SNMP MIBs.
-- QoS should be configured and applied on the interface(s) for which you will do SNMP polling.


policy that we apply in either direction on the interface of the router/switch
Router(config-if)#service-policy ?
input Assign policy-map to the input of an interface
output Assign policy-map to the output of an interface
type Configure CPL Service Policy

type is something different which is not there on the above document.

---------steps and output------------

6500 Switch 

class-map type lan-queuing match-all VIDEO
!
policy-map type lan-queuing SUP2T_OUT
!
interface GigabitEthernet6/1
ip address 10.106.39.127 255.255.255.0
service-policy type lan-queuing output SUP2T_OUT

-------------------


config 1 (type) 
class-map type lan-queuing match-all VIDEO
!
policy-map type lan-queuing SUP2T_OUT
!
interface GigabitEthernet6/1
ip address 10.106.39.127 255.255.255.0
service-policy type lan-queuing output SUP2T_OUT


SNMPWALK
4/27/2020 9:59:34 AM (5 ms) : Device: 10.106.39.127
4/27/2020 9:59:34 AM (14 ms) : SNMP V2c
4/27/2020 9:59:34 AM (20 ms) : Walk 1.3.6.1.4.1.9.9.166.1.1.1.1

4/27/2020 9:59:44 AM (3 ms) : Device: 10.106.39.127
4/27/2020 9:59:44 AM (4 ms) : SNMP V2c
4/27/2020 9:59:44 AM (4 ms) : Walk 1.3.6.1.4.1.9.9.166.1.1.1.1.2

4/27/2020 9:59:59 AM (3 ms) : Device: 10.106.39.127
4/27/2020 9:59:59 AM (6 ms) : SNMP V2c
4/27/2020 9:59:59 AM (10 ms) : Walk 1.3.6.1.4.1.9.9.166.1.1.1.1.3

4/27/2020 10:00:10 AM (4 ms) : Device: 10.106.39.127
4/27/2020 10:00:10 AM (6 ms) : SNMP V2c
4/27/2020 10:00:10 AM (8 ms) : Walk 1.3.6.1.4.1.9.9.166.1.1.1.1.4

4/27/2020 10:00:20 AM (4 ms) : Device: 10.106.39.127
4/27/2020 10:00:20 AM (5 ms) : SNMP V2c
4/27/2020 10:00:20 AM (7 ms) : Walk 1.3.6.1.4.1.9.9.166.1.6.1.1.1
4/27/2020 10:00:20 AM (59 ms) : 1.3.6.1.4.1.9.9.166.1.6.1.1.1.5743392 = "SUP2T_OUT" [ASN_OCTET_STR]

as we can see there is no cbQosIfIndex or other related info when queuing is used under interface(type)


config 2 (input) 

class-map match-all ICMP
!
policy-map SINGLE-RATE-TWO-COLOR
class ICMP
police 128000 conform-action transmit exceed-action drop

interface GigabitEthernet6/1
ip address 10.106.39.127 255.255.255.0
service-policy input SINGLE-RATE-TWO-COLOR

SNMPWALK
4/27/2020 10:03:37 AM (4 ms) : Device: 10.106.39.127
4/27/2020 10:03:37 AM (5 ms) : SNMP V2c
4/27/2020 10:03:37 AM (7 ms) : Walk 1.3.6.1.4.1.9.9.166.1.1.1.1
4/27/2020 10:03:37 AM (68 ms) : 1.3.6.1.4.1.9.9.166.1.1.1.1.2.144 = "1" [ASN_INTEGER]
4/27/2020 10:03:38 AM (118 ms) : 1.3.6.1.4.1.9.9.166.1.1.1.1.3.144 = "1" [ASN_INTEGER]
4/27/2020 10:03:38 AM (178 ms) : 1.3.6.1.4.1.9.9.166.1.1.1.1.4.144 = "9" [ASN_INTEGER]
4/27/2020 10:03:38 AM (218 ms) : 1.3.6.1.4.1.9.9.166.1.1.1.1.5.144 = "0" [ASN_INTEGER]
4/27/2020 10:03:38 AM (279 ms) : 1.3.6.1.4.1.9.9.166.1.1.1.1.6.144 = "0" [ASN_UNSIGNED]
4/27/2020 10:03:38 AM (353 ms) : 1.3.6.1.4.1.9.9.166.1.1.1.1.7.144 = "0" [ASN_UNSIGNED]
4/27/2020 10:03:38 AM (416 ms) : 1.3.6.1.4.1.9.9.166.1.1.1.1.8.144 = "0" [ASN_INTEGER]

4/27/2020 10:03:52 AM (5 ms) : Device: 10.106.39.127
4/27/2020 10:03:52 AM (9 ms) : SNMP V2c
4/27/2020 10:03:52 AM (11 ms) : Walk 1.3.6.1.4.1.9.9.166.1.1.1.1.2
4/27/2020 10:03:52 AM (127 ms) : 1.3.6.1.4.1.9.9.166.1.1.1.1.2.144 = "1" [ASN_INTEGER]

4/27/2020 10:04:06 AM (12 ms) : Device: 10.106.39.127
4/27/2020 10:04:06 AM (20 ms) : SNMP V2c
4/27/2020 10:04:06 AM (26 ms) : Walk 1.3.6.1.4.1.9.9.166.1.1.1.1.3
4/27/2020 10:04:06 AM (70 ms) : 1.3.6.1.4.1.9.9.166.1.1.1.1.3.144 = "1" [ASN_INTEGER]

4/27/2020 10:04:20 AM (11 ms) : Device: 10.106.39.127
4/27/2020 10:04:20 AM (17 ms) : SNMP V2c
4/27/2020 10:04:20 AM (24 ms) : Walk 1.3.6.1.4.1.9.9.166.1.1.1.1.4
4/27/2020 10:04:21 AM (750 ms) : 1.3.6.1.4.1.9.9.166.1.1.1.1.4.144 = "9" [ASN_INTEGER]


4/27/2020 10:05:22 AM (15 ms) : Device: 10.106.39.127
4/27/2020 10:05:22 AM (24 ms) : SNMP V2c
4/27/2020 10:05:22 AM (32 ms) : Walk 1.3.6.1.4.1.9.9.166.1.6.1.1.1
4/27/2020 10:05:22 AM (104 ms) : 1.3.6.1.4.1.9.9.166.1.6.1.1.1.15531008 = "SINGLE-RATE-TWO-COLOR" [ASN_OCTET_STR]


---------------------------------------


----------
Here is the objects we are trying to poll.
----------------------------------
QOS Object to poll
Object cbQosServicePolicyEntry
OID 1.3.6.1.4.1.9.9.166.1.1.1.1
Type CbQosServicePolicyEntry


Object cbQosIfType
OID 1.3.6.1.4.1.9.9.166.1.1.1.1.2
Type InterfaceType
1:mainInterface
2:subInterface
3:frDLCI
4:atmPVC
5:controlPlane
6:vlanPort
7:evc

Object cbQosPolicyDirection
OID 1.3.6.1.4.1.9.9.166.1.1.1.1.3
Type TrafficDirection
1:input
2:output


Object cbQosIfIndex
OID 1.3.6.1.4.1.9.9.166.1.1.1.1.4
Type InterfaceIndex


Object cbQosPolicyMapName 
OID 1.3.6.1.4.1.9.9.166.1.6.1.1.1
Type DisplayString

if applied
----------

'type' keyword/syntax is just not a difference between lab and the live setup, it has a significance in the configuration context, it changes to policy-based queueing. 
There is no SNMP indexing available for CPL/policy-based queuing as shown above.
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.