Guest

Preview Tool

Cisco Bug: CSCvt07259 - vManange: Loopback Feature template doesn't verify ipv4 subnet mask

Last Modified

Apr 22, 2020

Products (1)

  • Cisco SD-WAN

Known Affected Releases

19.2.99

Description (partial)

Symptom:
Device template may not attach to an edge device.

You may get the following error message in the task view during the attach stage:

[16-Feb-2020 20:41:43 EST] Configuring device with feature template: Basic_vedge_cloud_implementation
[16-Feb-2020 20:41:43 EST] Generating configuration from template
[16-Feb-2020 20:41:44 EST] Failed to update configuration - Error on line 14: invalid value for: address in /ncs:devices/ncs:device[ncs:name='vip_internal_temp_device_xxxxxxxxxxxxxx']/ncs:config/viptela-vpn:vpn/viptela-vpn:vpn-instance[viptela-vpn:vpn-id='0']/viptela-vpn:interface[viptela-vpn:if-name='loopback1']/viptela-vpn:ip/viptela-vpn:address: "X.X.X.X" is an invalid value.

Conditions:
If you use loopback interface feature template.
if you set the IPv4 for the loopback interface as a variable.
If you try to attach the device template to a device/controller.
if you only input the ip address without a subnet mask.
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.