Guest

Preview Tool

Cisco Bug: CSCvs72482 - On trying to remove the native vlan config from an interface, DCNM also removes the allowed vlans.

Last Modified

May 22, 2020

Products (1)

  • Cisco Data Center Network Manager

Known Affected Releases

11.1(1)

Description (partial)

Symptom:
On trying to remove the native vlan config from an interface, DCNM also removes the allowed vlans.

Conditions:
When a port is configured as trunk host using int_trunk_host_11_1 policy, and the vlan id for "switchport trunk native vlan <vlan-id>" command is also part of trunk allowed vlan list. On trying to remove the native vlan, DCNM also removes all the allowed vlans from the allowed vlan list.

For example, intent is:
interface Ethernet1/30
  no shutdown
  description SLOT1.NODE1
  spanning-tree port type edge trunk
  spanning-tree bpduguard enable
  mtu 9216
  switchport
  switchport mode trunk
  switchport trunk allowed vlan 104,111,112,113
  switchport trunk native vlan 104
  switchport

Running config is:
interface Ethernet1/30
  description SLOT1.NODE1
  switchport
  switchport mode trunk
  switchport trunk native vlan 104
  switchport trunk allowed vlan 104,111-113
  spanning-tree port type edge trunk
  spanning-tree bpduguard enable
  mtu 9216
  no shutdown

After removing "switchport trunk native vlan 104" from intent, DCNM generates following config that removes all the allowed vlans:
interface ethernet1/30
  no switchport trunk native vlan 104
  switchport
  switchport mode trunk
  mtu 9216
  spanning-tree bpduguard enable
  spanning-tree port type edge trunk
  description SLOT1.NODE1
  no shutdown
  no switchport trunk allowed vlan 104,111-113
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.