Guest

Preview Tool

Cisco Bug: CSCvs71834 - ASR903 - stops forwarding over VC after dot1.q tag is removed and added back to service instance

Last Modified

Oct 09, 2020

Products (1)

  • Cisco ASR 900 Series Aggregation Services Routers

Known Affected Releases

16.12.1

Description (partial)

Symptom:
ASR903 stops forwarding traffic over VC after dot1.q tag is removed and added back to range in service instance.

Conditions:
RECULE


interface GigabitEthernet0/1/3
 description TEST
 mtu 1600
 no ip address
 load-interval 30
 negotiation auto
 cdp enable
 no keepalive
 service instance 2 ethernet
  description TEST
  encapsulation default
  xconnect 2.2.2.2 100 encapsulation mpls pw-class cisco-eth
 !
!

RECULE#sh mpls l2 vc

Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
Gi0/1/3        Ethernet:2                 2.2.2.2         100        UP


SAMCARTER

interface GigabitEthernet0/2
 description TEST
 switchport trunk allowed vlan none
 switchport mode trunk
 mtu 1600
 load-interval 30
 service instance 2 ethernet
  description TEST
  encapsulation dot1q 100 second-dot1q 1010-3409
  xconnect 1.1.1.1 100 encapsulation mpls
 !

SAMCARTER#sh mpls l2 vc

Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
Gi0/2          Ethernet:2                 1.1.1.1         100        UP

++ Ping works both ways:

DANIELJACKSON#ping vrf test 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

=== add new instance ===

RECULE

interface GigabitEthernet0/1/3
 description TEST
 mtu 1600
 no ip address
 load-interval 30
 negotiation auto
 cdp enable
 no keepalive
 service instance 2 ethernet
  description TEST
  encapsulation default
  xconnect 2.2.2.2 100 encapsulation mpls pw-class cisco-eth
 !
 service instance 3 ethernet
  description NEW
  encapsulation dot1q 100 second-dot1q 1010
  xconnect 2.2.2.2 200 encapsulation mpls pw-class cisco-eth
 !

 RECULE#sh mpls l2 vc

Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
Gi0/1/3        Ethernet:2                 2.2.2.2         100        UP
Gi0/1/3        Eth VLAN 100/1010          2.2.2.2         200        UP


SAMCARTER

SAMCARTER#sh run int gi0/2
Building configuration...

Current configuration : 419 bytes
!
interface GigabitEthernet0/2
 description TEST
 switchport trunk allowed vlan none
 switchport mode trunk
 mtu 1600
 load-interval 30
 service instance 2 ethernet
  description TEST
  encapsulation dot1q 100 second-dot1q 1010-3409
  xconnect 1.1.1.1 100 encapsulation mpls
 !
 service instance 3 ethernet
  description NEW
  encapsulation dot1q 200 second-dot1q 1010
  xconnect 1.1.1.1 200 encapsulation mpls
 !
end

SAMCARTER#sh mpls l2 vc

Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
Gi0/2          Ethernet:2                 1.1.1.1         100        UP
Gi0/2          Eth VLAN 200/1010          1.1.1.1         200        UP

++ Ping no longer works:

DANIELJACKSON#ping vrf test 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)


======= Now remove the NEW instance =======

RECULE

interface GigabitEthernet0/1/3
 description TEST
 mtu 1600
 no ip address
 load-interval 30
 negotiation auto
 cdp enable
 no keepalive
 service instance 2 ethernet
  description TEST
  encapsulation default
  xconnect 2.2.2.2 100 encapsulation mpls pw-class cisco-eth
 !

 RECULE#sh mpls l2 vc

Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
Gi0/1/3        Ethernet:2                 2.2.2.2         100        UP


SAMCARTER

interface GigabitEthernet0/2
 description TEST
 switchport trunk allowed vlan none
 switchport mode trunk
 mtu 1600
 load-interval 30
 service instance 2 ethernet
  description TEST
  encapsulation dot1q 100 second-dot1q 1010-3409
  xconnect 1.1.1.1 100 encapsulation mpls
 !

 SAMCARTER#sh mpls l2 vc

Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
Gi0/2          Ethernet:2                 1.1.1.1         100        UP

++ Ping still does not work, even that we have same config as originaly when it worked:

DANIELJACKSON#ping vrf test 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.