Guest

Preview Tool

Cisco Bug: CSCvs47052 - FTP source-interface loopback is using the wrong source interface

Last Modified

Jan 13, 2020

Products (1)

  • Cisco IOS

Known Affected Releases

16.12.1

Description (partial)

Symptom:
When configuring a Catalyst 9K with "ip ftp source-interface loopback 104" the FTP transfer is sourcing loopback 0.

Conditions:
C9400-1#sho run | i ftp
ip ftp source-interface Loopback104
ip ftp username cisco
ip ftp password cisco
C9400-1#
C9400-1#
C9400-1#sho run int vlan 104
Building configuration...

Current configuration : 273 bytes
!
interface Vlan104
 description User Access IAN
 vrf forwarding IAN
 ip address 24.0.20.1 255.255.255.0
 ip helper-address global 10.222.118.112
 load-interval 30
 ipv6 address 2024:0:4:4::1/64
 ipv6 enable
 ipv6 nd ra dns server 2001:4898:2001:8:FE::3
 no autostate
end

C9400-1#
C9400-1#show ip route 24.0.0.10
Routing entry for 24.0.0.10/32
  Known via "connected", distance 0, metric 0 (connected, via interface)
  Redistributing via bgp 65538
  Advertised by bgp 65538 route-map CONNECTEDv4
  Routing Descriptor Blocks:
  * directly connected, via Loopback0
      Route metric is 0, traffic share count is 1
C9400-1#show run int loo 0
Building configuration...

Current configuration : 108 bytes
!
interface Loopback0
 ip address 24.0.0.10 255.255.255.255
 ip mtu 9014
 ipv6 address 2024:3:1::A/128
end


**************  Packet capture shows source as 24.0.0.10 ****************
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.