Guest

Preview Tool

Cisco Bug: CSCvs17939 - Database replication is broken in HA OnPrem

Last Modified

Dec 13, 2019

Products (1)

  • Cisco Smart Software Manager satellite

Known Affected Releases

7-2019077-201910

Description (partial)

Symptom:
Products added, and other changes made on the Active node is not being replicated to the Standby node.

Conditions:
both Active and Standby Nodes are in slave replication mode.
SSH into box, run onprem-console, run ha_status.

When in this broken state, both nodes will show output indicating a slave/replication state:

```
=========================================================================
Database Replication Status:
=========================================================================

Replication to slave:
 client_addr | backend_start | state | write_lag | flush_lag | replay_lag
-------------+---------------+-------+-----------+-----------+------------
(0 rows)


Replication from master:
 pg_last_xlog_replay_location
------------------------------
 0/13000000
(1 row)
```
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.