Guest

Preview Tool

Cisco Bug: CSCvs10279 - MPLS ping implicit null drops at counter IPV4_TTL_ERROR

Last Modified

Jun 19, 2020

Products (11)

  • Cisco ASR 9000 Series Aggregation Services Routers
  • Cisco ASR 9910 Router
  • Cisco ASR 9922 Router
  • Cisco IOS XR Software
  • Cisco ASR 9010 Router
  • Cisco ASR 9904 Router
  • Cisco ASR 9006 Router
  • Cisco ASR 9001 Router
  • Cisco ASR 9901 Router
  • Cisco ASR 9906 Router
View all products in Bug Search Tool Login Required

Known Affected Releases

6.0.2.FWDG 6.0.2.MPLS 6.6.3.BASE

Description (partial)

Symptom:
MPLS/Normal ping & trace packets towards the problematic prefix, are dropped at NP counter "IPV4_TTL_ERROR"

-> When we did MPLS ping, we could see that counter IPV4_TTL_ERROR was incrementing equally. 
-> Whenever MPLS ping was stopped, counter increment also stopped.

RP/0/RSP0/CPU0:R3#ping mpls ipv4 4.4.4.4/32 source 3.3.3.3
Sun Aug 18 03:09:35.155 UTC
Sending 5, 100-byte MPLS Echos to 4.4.4.4/32,
      timeout is 2 seconds, send interval is 0 msec:
Type escape sequence to abort.
.....
Success rate is 0 percent (0/5)


RP/0/RSP0/CPU0:R1#sh controllers np counters np1 loc 0/3/cpu0 | i "ERR|DR$
 840  IPV4_TTL_ERROR                                          1045           0
RP/0/RSP0/CPU0:R1#sh controllers np counters np1 loc 0/3/cpu0 | i "ERR|DR$
 840  IPV4_TTL_ERROR                                          1047           1
RP/0/RSP0/CPU0:R1#sh controllers np counters np1 loc 0/3/cpu0 | i "ERR|DR$
 840  IPV4_TTL_ERROR                                          1048           0
RP/0/RSP0/CPU0:R1#sh controllers np counters np1 loc 0/3/cpu0 | i "ERR|DR$
 840  IPV4_TTL_ERROR                                          1050           1
RP/0/RSP0/CPU0:R1#sh controllers np counters np1 loc 0/3/cpu0 | i "ERR|DR$
 840  IPV4_TTL_ERROR                                          1051           0
RP/0/RSP0/CPU0:R1#sh controllers np counters np1 loc 0/3/cpu0 | i "ERR|DR$
 840  IPV4_TTL_ERROR                                          1053           1
RP/0/RSP0/CPU0:R1#sh controllers np counters np1 loc 0/3/cpu0 | i "ERR|DR$
 840  IPV4_TTL_ERROR                                          1054           0
RP/0/RSP0/CPU0:R1#sh controllers np counters np1 loc 0/3/cpu0 | i "ERR|DR$
 840  IPV4_TTL_ERROR                                          1056           1
RP/0/RSP0/CPU0:R1#sh controllers np counters np1 loc 0/3/cpu0 | i "ERR|DR$
 840  IPV4_TTL_ERROR                                          1057           0

-> This counters says that traffic is dropping because of 0 TTL in packet. 
-> We tried to ping by defining TTL 255 as well but same results.

Problem was only with implicit-null and explicit-null was working fine. 
There was no traffic impact

-> Tried reload of the problematic 100 Gig LC, but didn't resolve this issue

Conditions:
When Tomahawk link is elected from ECMP
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.