Guest

Preview Tool

Cisco Bug: CSCvs02364 - AMQP is not running after amqp restart post upgrade

Last Modified

Jun 15, 2020

Products (1)

  • Cisco Data Center Network Manager

Known Affected Releases

11.3(0.417)

Description (partial)

Symptom:
HA post upgrade from 11.2(1)/11.3(1) to 11.4(1), AMQP is not running after amqp restart

Logs from the upgrade window:
  [root@sol-amr1-dcnm2 ~]# appmgr status amqp
Error: unable to perform an operation on node 'rabbit@sol-amr1-dcnm2'. Please see diagnostics information and suggestions below.
 
Most common reasons for this are:
 
* Target node is unreachable (e.g. due to hostname resolution, TCP connection or firewall issues)
* CLI tool fails to authenticate with the server (e.g. due to CLI tool's Erlang cookie not matching that of the server)
* Target node is not running
 
In addition to the diagnostics info below:
 
* See the CLI, clustering and networking guides on http://rabbitmq.com/documentation.html to learn more
* Consult server logs on node rabbit@sol-amr1-dcnm2
 
DIAGNOSTICS
===========
 
attempted to contact: ['rabbit@sol-amr1-dcnm2']
 
rabbit@sol-amr1-dcnm2:
  * connected to epmd (port 4369) on sol-amr1-dcnm2
  * epmd reports: node 'rabbit' not running at all
                  no other nodes on sol-amr1-dcnm2
  * suggestion: start the node

Conditions:
post upgrade, if we restart the amqp, amqp wont start as expected in both active and standby
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.