Guest

Preview Tool

Cisco Bug: CSCvj17232 - New VLAN in existing Flex Link VLB setup gets forwarded on both Active and Backup interfaces

Last Modified

Apr 27, 2018

Products (1)

  • Cisco ME 3800X Series Carrier Ethernet Switch Routers

Known Affected Releases

15.4(3)SS

Description (partial)

Symptom:
Whenever a new VLAN is created on the existing setup, this new VLAN is forwarded on both the Active AND Backup links.

Conditions:
A new VLAN gets created in an existing Flex Link VLB setup that has been working fine. For example:

VLAN 169 did NOT exist on the Switch initially when the Flex Link solution was brought up, but it was already permitted in the switchport trunk allowed VLAN list:


interface GigabitEthernet0/1
description LINK TO TT-H8-ME-FF-AGG-3750X-1 Gi1/1/3 (Backup Flex Uplink)
switchport trunk allowed vlan 1-1713,1715-2000,2002-2005,2007-2027,2029-2069
switchport trunk allowed vlan add 2071-2073,2075-4094
switchport mode trunk
load-interval 30
no cdp enable
spanning-tree portfast trunk
spanning-tree bpdufilter enable
end

!
interface GigabitEthernet0/2
description LINK TO SGR-ME-MX240 GE-1/3/0 (Active Flex Uplink)
switchport trunk allowed vlan 1-2000,2002-2005,2007-2027,2029-2069,2071-2073
switchport trunk allowed vlan add 2075-4094
switchport mode trunk
switchport backup interface Gi0/1
switchport backup interface Gi0/1 prefer vlan 50
logging event link-status
load-interval 30
no cdp enable
spanning-tree portfast trunk
spanning-tree bpdufilter enable
end

As you can see ONLY Vlan 50 is configured to use the Backup interface (Gi0/1) BUT after adding the NEW Vlan (169), it's being forwarded on both Active AND Backup interfaces:

Port                Vlans in spanning tree forwarding state and not pruned
Gi0/1               50,169
Gi0/2               1,10,19,21,28,50,52,57,74,113,128,132,169,186,216,226,229,247,268,270,272,311,317,337-338,383,386,390-391,455,474,524,674,882,888,960,978,1001-1005,1103,1143,1165,1256,1268,1271,1400,1444,1451,1480,1513,1567-1568,1576,1581-1582,1586,1714,1921,1927,1935,1983,1998,2131,2133,2214,2245,2990,3021,3694,4008

F340.03.04-3800X-1#sh int switchport backup

Switch Backup Interface Pairs:

Active Interface        Backup Interface        State
------------------------------------------------------------------------
GigabitEthernet0/2      GigabitEthernet0/1      Active VLB cfg/Backup VLB cfg
        Vlans Preferred on Active Interface: 1-49,51-4094
        Vlans Preferred on Backup Interface: 50
        Preemption Mode  : off
        Preemption Delay : 35 seconds (default)
        Multicast Fast Convergence  : Off
        Bandwidth : 100000 Kbit (Gi0/2), 100000 Kbit (Gi0/1)
        Mac Address Move Update Vlan : auto



It's even learning MACs on that VLAN on BOTH interfaces:


F340.03.04-3800X-1#sh mac address-table vlan 169
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
All    0100.0000.0000    STATIC      CPU
All    0100.0ccc.cccc    STATIC      CPU
All    0100.0ccc.cccd    STATIC      CPU
All    0100.0ccc.ccce    STATIC      CPU
All    0100.0ccd.cdd0    STATIC      CPU
All    0100.0cdd.dddd    STATIC      CPU
All    0180.c200.0000    STATIC      CPU
All    0180.c200.0001    STATIC      CPU
All    0180.c200.0002    STATIC      CPU
All    0180.c200.0003    STATIC      CPU
All    0180.c200.0004    STATIC      CPU
All    0180.c200.0005    STATIC      CPU
All    0180.c200.0006    STATIC      CPU
All    0180.c200.0007    STATIC      CPU
All    0180.c200.0008    STATIC      CPU
All    0180.c200.0009    STATIC      CPU
All    0180.c200.000a    STATIC      CPU
All    0180.c200.000b    STATIC      CPU
All    0180.c200.000c    STATIC      CPU
All    0180.c200.000d    STATIC      CPU
All    0180.c200.000e    STATIC      CPU
All    0180.c200.000f    STATIC      CPU
All    0180.c200.0010    STATIC      CPU
All    ffff.ffff.ffff    STATIC      CPU
169    0012.431d.e504    DYNAMIC     Gi0/1
169    0064.40ed.8504    DYNAMIC     Gi0/2
Total Mac Addresses for this criterion: 26
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.