Guest

Preview Tool

Cisco Bug: CSCvi61862 - SLES11 zypper install wil not pick the right RPM from repo

Last Modified

Apr 06, 2018

Products (1)

  • Cisco Tetration Analytics

Known Affected Releases

2.2(1.34) 2.2(1.35)

Description (partial)

Symptom:
Customer copy all 4 agent packages (rhel6, rhel7, sles11, sles12) into a directory in their repo server. Then on the end host, sles11, they run
    run zypper ref -s
    run zypper install -y tet-sensor-site

It attempts to install the rhel6 package instead of the sles11 package to the end host.

When the admin requesting 'information' about the package returns information about the rhel6 package:
  zypper info tet-sensor-site
  Loading repository data...
  Reading installed packages...
  
  Information for package tet-sensor-site:
 
  Repository: Cisco Tetration Agents
  Name: tet-sensor-site
  Version: 2.2.1.34-1
  Arch: x86_64
  Vendor:
  Support Level: unknown
  Installed: No
  Status: not installed
  Installed Size: 1.7 MiB
  Summary: Host Sensor
  Description:
  host sensor - .el6 - host001.enforcer
 
The 'right thing' (i.e. rhel7 package is used on rhel7) happens for rhel6, rhel7 and sles12. sles11 is the one having this issue.

Conditions:
when zypper install on sles11 (SUSE), it pull the wrong file from the repo
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.