Guest

Preview Tool

Cisco Bug: CSCuw44584 - Stack reloads introducing "no switch XX provision"with ACL applied in XX

Last Modified

Sep 13, 2018

Products (23)

  • Cisco Catalyst 2960-X Series Switches
  • Cisco Catalyst 2960X-24PS-L Switch
  • Cisco Catalyst 2960X-24PD-L Switch
  • Cisco Catalyst 2960X-48LPS-L Switch
  • Cisco Catalyst 2960X-24TS-LL Switch
  • Cisco Catalyst 2960X-48TS-LL Switch
  • Cisco Catalyst 2960X-48TD-L Switch
  • Cisco Catalyst 2960XR-24TS-I Switch
  • Cisco Catalyst 2960XR-48FPS-I Switch
  • Cisco Catalyst 2960XR-24TD-I Switch
View all products in Bug Search Tool Login Required

Known Affected Releases

15.0(2)EX1

Description (partial)

Symptom:
You could crash when you have a stack with several switches and switch XX has one interface which applies an ACL , then you remove phisically switch XX and you perform the command "no switch 4 provision" the device crashes.

ipv6 access-list IPv6_FH_SECURITY
 remark Block IPv6 DHCP Server
 deny udp any  eq 547 any  eq 546
 remark Block Router Advertisements
 deny icmp any any  router-advertisement
 permit ipv6 any any

interface GigabitEthernet4/0/1
 switchport access vlan 160
 switchport mode access
 switchport port-security maximum 3
 switchport port-security
 switchport port-security aging time 1
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 no logging event link-status
 power inline auto max 15400
 ipv6 traffic-filter IPv6_FH_SECURITY in  <<<<<<<<<
 no snmp trap link-status

*** Then, we remove switch 4****

Switch Ports Model              SW Version            SW Image
------ ----- -----              ----------            ----------
     1 52    WS-C2960X-48TD-L   15.0(2a)EX5           C2960X-UNIVERSALK9-M
     2 52    WS-C2960X-48TD-L   15.0(2a)EX5           C2960X-UNIVERSALK9-M
*    3 52    WS-C2960X-48TD-L   15.0(2a)EX5           C2960X-UNIVERSALK9-M

513E.B.11-2900-8#config t
Enter configuration commands, one per line.  End with CNTL/Z.
513E.B.11-2900-8(config)#no switch
513E.B.11-2900-8(config)#no switch provisi
513E.B.11-2900-8(config)#no switch 4 provision


 20:08:28 UTC Mon Sep 28 2015: Unexpected exception to CPUvector 1100, PC = 1FD095C
-Traceback= 0x1FD095Cz 0x1FDF060z 0x1FB1EFCz 0x27158E8z 0x270F928z

Conditions:
To have applied an ACL to one interface of the switch that has been removed.
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.