Guest

Preview Tool

Cisco Bug: CSCus51858 - CWS Connector service appears as started even in case of fault

Last Modified

Jun 08, 2016

Products (1)

  • Cisco Cloud Web Security

Known Affected Releases

3.0(1.2) 3.0(1.7) 3.0(1.9)

Description (partial)

Symptom:
Connector is not reachable by clients after starting the connector service.

Conditions:
When the user is trying to start the Connector service from "Services" tool in Windows he will see that service is started even in the case when service has failed to start.  Connector status in "Services" tool shows "Started".

To determine if the service has not started, look in the connector.log file for messages similar to the following: 

29-07-2013 10:23:38,768 [Thread-1] ERROR qc - Failed to start! 
f: Configured license key does not conform to a valid format: 10EEE7F20E6743B62F676900C1A9982D
at ib.a(Unknown Source)
at ib.a(Unknown Source)
at ib.a(Unknown Source)
at qc.a(Unknown Source)
at proxyagent.Main.a(Unknown Source)
at proxyagent.Main.main(Unknown Source)

The Connector is not active and not reachable for clients but we do not any feedback in Windows "Services" tool since it displays as "Started"  

This behavior also happens on the Linux platforms.   You can see following message during the start attempt:

[root@connector32 ~]# service connector start
Starting Connector: [ OK ]
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.