Guest

Preview Tool

Cisco Bug: CSCus42819 - JANUARY 2015 OpenSSL Vulnerabilities

Last Modified

Jan 30, 2016

Products (1)

  • Cisco NetFlow Generation 3000 Series Appliances

Known Affected Releases

1.0(0.0) 1.0(1) 1.0(2) 1.0(3) 1.1(1)

Description (partial)

This vulnerability will be addressed in a patch for NGA 1.0.3
Target date: May, 2015

Symptom:

This product includes a version of OpenSSL that is affected by the vulnerability identified by the Common Vulnerability and Exposures (CVE) IDs:

CVE-2014-3569, CVE-2014-3570, CVE-2014-3571, CVE-2014-3572, CVE-2014-8275, CVE-2015-0204, CVE-2015-0205, CVE-2015-0206

This bug has been opened to address the potential impact on this product.



Conditions:

Exposure is not configuration dependent.

CVE-2014-3569 NGA is not vulnerable
All versions do not use 'no-ssl3' during compilation

CVE-2014-3570 NGA versions including 1.0.3 are vulnerable
Versions < 6.2 are vulnerable. However, the attack vector is small and there are no known exploits.

CVE-2014-3571 NGA version 1.0.3 is vulnerable
All versions prior to 1.0.3 to not support DTLS negotiation. NGA version 1.0.3 is vulnerable.

CVE-2014-3572 NGA versions including 1.0.3 are vulnerable
Versions < 1.0.3 are vulnerable. Customers are encouraged to update to NGA 1.0.3 if they are concerned about this vulnerability. NGA 1.0.3 is not vulnerable.

CVE-2014-8275 NGA versions up to 1.0.3 are vulnerable
Versions < 1.0.3 are vulnerable. Customers are encouraged to update to NGA 1.0.3 if they are concerned about this vulnerability. NGA 1.0.3 is not vulnerable.

CVE-2015-0204 NGA versions including 1.0.3 are vulnerable
Versions < 1.0.3 are vulnerable. Customers are encouraged to update to NGA 1.0.3 if they are concerned about this vulnerability. NGA 1.0.3 is not vulnerable.

CVE-2015-0205 NGA versions including 1.0.3 are vulnerable
Versions < 1.0.3 are vulnerable. Customers are encouraged to update to NGA 1.0.3 if they are concerned about this vulnerability. NGA version 1.0.3 is vulnerable.

CVE-2015-0206 NGA version 1.0.3 is vulnerable
All versions prior to 1.0.3 to not support DTLS negotiation and are not vulnerable. NGA version 1.0.3 is vulnerable.

Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.