Guest

Preview Tool

Cisco Bug: CSCus26759 - inconsistent results when attribute value has trailing spaces

Last Modified

Sep 20, 2016

Products (1)

  • Cisco MATE Live

Known Affected Releases

5.4 6.0 6.1

Description (partial)

Symptom:
inconsistent results when attribute value has trailing spaces

Conditions:
In the demo database there are 12 nodes with a model name of "CRS-16/S" and 2 nodes with a model name of "CRS-16/S  " <-- note the trailing two spaces.  If you run a report with a filter of model="CRS-16/S" you will get a report with all 14 nodes, which is expected.  Similarly, if you run a report with a filter of model="CRS-16/S  ", you get a report with only 2 nodes, which is consistent.  However, it's not possible to see trailing spaces in our UI, nor are they handled consistently.  It's not possible to use the explorer to filter on model="CRS-16/S  "  ("CRS-16/S.." doesn't work either.)  From the explorer, it's not possible to distinguish between the two models.  However, the report builder will present two filters for model.  If you pick the wrong one, the results will be surprising.  See screenshots.  A minor problem with an easy workaround.  Unless you want to find just the models with trailing spaces.  This is not easily done with the product.  We should probably implicitly trim spaces from attributes, or at least do queries where trailing spaces are ignored.  Fails in 5.4, 6.0 & 6.1.  Demo data.  Not a regression.
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.