Guest

Preview Tool

Cisco Bug: CSCur69189 - interface arp not resolved--ping failed with bgp/ospf/ospfv3/ldp enabled

Last Modified

Jan 11, 2017

Products (1)

  • Cisco Carrier Routing System

Known Affected Releases

5.4.0.BASE

Description (partial)

Symptom:
With three physical interfaces configured with ipv4/ipv6, and routing protocols enabled (ebgp/ospf/ospfv3/ldp), even without any injected routes and traffic, the interface arp is not resolved and back to back ping failed.

The EFR is sunstone-dev   EFR-00000290209

Conditions:
sunstone configuration:
RP/0/RP0/CPU0:ott02-sim-09-uut#sh run
Wed Nov 12 20:32:12.095 UTC
Building configuration...
!! IOS XR Configuration version = 5.3.0.03C
!! Last configuration change at Wed Nov 12 17:35:06 2014 by root
!
hostname ott02-sim-09-uut
logging console debugging
logging buffered 125000000
username root
 group root-lr
 group cisco-support
 secret 5 $1$HZHO$S0YwjfyA2H6QR5qeLpoTQ/
!
line console
 timestamp disable
 exec-timeout 0 0
!
interface Loopback0
 ipv4 address 101.0.0.1 255.255.255.255
 ipv6 address 101::1/128
!
interface Loopback1
 ipv4 address 101.0.1.1 255.255.255.255
 ipv6 address 101:1::1/128
!
interface Loopback2
 ipv4 address 101.0.2.1 255.255.255.255
 ipv6 address 101:2::1/128
!
interface MgmtEth0/RP0/CPU0/0
 shutdown
!
interface GigabitEthernet0/RP0/CPU0/4
 shutdown
!
interface GigabitEthernet0/RP0/CPU0/5
 shutdown
!
interface GigabitEthernet0/RP0/CPU0/6
 shutdown
!
interface TenGigE0/RP0/CPU0/0
 description interface7 -> ott02-sim-09-r1:Te0/3/0/0
 mtu 1514
 ipv4 address 91.1.0.1 255.255.255.0
 ipv6 address 901:a01:1::1/112
 load-interval 30
!
interface TenGigE0/RP0/CPU0/1
 description interface9 -> ott02-sim-09-r1:Te0/3/0/1
 ipv4 address 91.2.0.1 255.255.255.0
 ipv6 address 901:a02:2::1/112
 load-interval 30
!
interface TenGigE0/RP0/CPU0/2
 ipv4 address 109.1.0.1 255.255.255.0
 ipv6 address 1009:a01:1::1/112
 shutdown
 load-interval 30
!
interface TenGigE0/RP0/CPU0/2.100
 ipv4 address 109.1.1.1 255.255.255.0
 ipv6 address 2002:6d01:100::1/112
 dot1q vlan 100
!
interface TenGigE0/RP0/CPU0/2.101
 ipv4 address 109.1.2.1 255.255.255.0
 ipv6 address 2002:6d01:100::1:1/112
 dot1q vlan 101
!
interface TenGigE0/RP0/CPU0/2.102
 ipv4 address 109.1.3.1 255.255.255.0
 ipv6 address 2002:6d01:100::2:1/112
 dot1q vlan 102
!
interface TenGigE0/RP0/CPU0/2.103
 ipv4 address 109.1.4.1 255.255.255.0
 ipv6 address 2002:6d01:100::3:1/112
 dot1q vlan 103
!
interface TenGigE0/RP0/CPU0/2.104
 ipv4 address 109.1.5.1 255.255.255.0
 ipv6 address 2002:6d01:100::4:1/112
 dot1q vlan 104
!
interface TenGigE0/RP0/CPU0/3
 description interface11 -> ott02-sim-09-r1:Te0/3/0/2
 ipv4 address 91.3.0.1 255.255.255.0
 ipv6 address 901:a03:3::1/112
 load-interval 30
!
prefix-set pass_ipv4_1_in
  52.0.0.0/32 le 32
end-set
!
prefix-set pass_ipv6_1_in
  151::/128 le 128
end-set
!
prefix-set pass_ipv4_1_out
  2.0.0.0/32 le 32
end-set
!
prefix-set pass_ipv6_1_out
  1::/128 le 128
end-set
!
route-policy drop
  drop
end-policy
!
route-policy pass-all
  pass
end-policy
!
route-policy pass_ipv4_1_in
  pass
end-policy
!
route-policy pass_ipv6_1_in
  pass
end-policy
!
route-policy pass_ipv4_1_out
  pass
end-policy
!
route-policy pass_ipv6_1_out
  pass
end-policy
!
router ospf 100
 nsr
 log adjacency changes
 router-id 101.0.0.1
 mtu-ignore enable
 maximum paths 32
 nsf cisco
 area 0
  interface Loopback0
   mtu-ignore enable
  !
  interface TenGigE0/RP0/CPU0/0
   mtu-ignore enable
  !
  interface TenGigE0/RP0/CPU0/2
   mtu-ignore enable
  !
  interface TenGigE0/RP0/CPU0/2.101
   mtu-ignore enable
  !
  interface TenGigE0/RP0/CPU0/3
   mtu-ignore enable
  !
 !
!
router ospfv3 100
 router-id 101.0.0.1
 maximum paths 32
 area 0
  interface Loopback0
  !
  interface TenGigE0/RP0/CPU0/0
  !
  interface TenGigE0/RP0/CPU0/2
  !
  interface TenGigE0/RP0/CPU0/3
  !
  interface TenGigE0/RP0/CPU0/2.101
  !
 !
 address-family ipv6 unicast
!
router bgp 200
 nsr
 bgp router-id 101.0.0.1
 bgp graceful-restart
 address-family ipv4 unicast
  maximum-paths ebgp 32
 !
 address-family vpnv4 unicast
 !
 address-family ipv6 unicast
 !
 neighbor 91.2.0.2
  remote-as 201
  address-family ipv4 unicast
   route-policy pass_ipv4_1_in in
   route-policy pass_ipv4_1_out out
  !
 !
 neighbor 109.1.1.2
  remote-as 300
  address-family ipv4 unicast
   route-policy pass-all in
   route-policy pass-all out
  !
 !
 neighbor 901:a02:2::2
  remote-as 201
  update-source TenGigE0/RP0/CPU0/1
  address-family ipv6 unicast
   route-policy pass_ipv6_1_in in
   route-policy pass_ipv6_1_out out
  !
 !
 neighbor 2002:6d01:100::3:2
  remote-as 300
  update-source TenGigE0/RP0/CPU0/2.103
  address-family ipv6 unicast
   route-policy pass-all in
   route-policy pass-all out
  !
 !
!
mpls ldp
 graceful-restart
 router-id 101.0.0.1
 address-family ipv4
 !
 interface TenGigE0/RP0/CPU0/0
  address-family ipv4
  !
 !
 interface TenGigE0/RP0/CPU0/1
  address-family ipv4
  !
 !
 interface TenGigE0/RP0/CPU0/2
 !
 interface TenGigE0/RP0/CPU0/3
  address-family ipv4
  !
 !
 interface TenGigE0/RP0/CPU0/2.101
 !
 interface TenGigE0/RP0/CPU0/2.102
 !
!
end

RP/0/RP0/CPU0:ott02-sim-09-uut#
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.