Guest

Preview Tool

Cisco Bug: CSCur61466 - DCPN30503 - QoS stats not working as MTS buffer queue is missing on VSM

Last Modified

Jan 31, 2017

Products (2)

  • Cisco Nexus 1000V Switch for VMware vSphere
  • Cisco Nexus 1000V Switch

Known Affected Releases

4.2(1)SV2(2.2)

Description (partial)

Symptom:
Occassionally during n1k install / config, some of the MTS buffer queues aren't which caused ipqos manager to not be able to provide qos stats

switch# show system internal mts buffers summary
node    sapno   recv_q  pers_q  npers_q log_q
sup     284     0       6       0       0


correct behavior is to have output like below

N1K# show system internal mts buffers summary
node    sapno   recv_q  pers_q  npers_q log_q
sup     284     0       6       0       0
sup     273     2       0       0       0
sup     268     2       0       0       0
sup     267     2       0       0       0
sup     250     2       0       0       0
sup     428     2       0       0       0  <<====== needed to qos stats
N1K#

Conditions:
QoS is setup as per white paper below

http://www.cisco.com/c/en/us/products/collateral/switches/nexus-1000v-switch-vmware-vsphere/white_paper_c11-704041.html

I was able to reproduce issue in the lab
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.