Guest

Preview Tool

Cisco Bug: CSCur57358 - Dataplane crashed due to number of ecmp paths being 0

Last Modified

Aug 07, 2018

Products (1)

  • Cisco Carrier Routing System

Known Affected Releases

5.4.0.BASE

Description (partial)

Symptom:
I have a setup with iBGP traffic (two streamsā€”ipv4 and ipv6 at 1% traffic rate each).
 
After starting traffic, saw the following from the console:
Receive of DPA header failed: Connection reset by peer
 
Then the DPC-DPA connection is reset.

Conditions:
IXIA--sunstone---ASR9K--IXIA

between sunstone---ASR9K, only one link in ospf--igp:
RP/0/RP0/CPU0:ott-ss-dt-01-uut#sh run router ospf
Wed Nov  5 18:36:08.252 UTC
router ospf 100
 nsr
 log adjacency changes
 router-id 101.0.0.1
 mtu-ignore enable
 maximum paths 32
 nsf cisco
 area 0
  interface Loopback0
   mtu-ignore enable
  !
  interface TenGigE0/RP0/CPU0/3
   mtu-ignore enable
  !
 !
!

RP/0/RP0/CPU0:ott-ss-dt-01-uut#

 !
!

RP/0/RP0/CPU0:ott-ss-dt-01-uut#sh run router bgp
Wed Nov  5 18:36:31.457 UTC
router bgp 1
 bgp router-id 101.0.0.1
 address-family ipv4 unicast
  redistribute connected
  redistribute ospf 100
 !
 address-family ipv6 unicast
  redistribute connected
  redistribute ospfv3 100
 !
 neighbor 102::1
  remote-as 1
  update-source Loopback0
  address-family ipv6 unicast
  !
 !
 neighbor 102.0.0.1
  remote-as 1
  update-source Loopback0
  address-family ipv4 unicast
  !
 !
 neighbor 109.1.0.2
  remote-as 6500
  address-family ipv4 unicast
   route-policy pass-all in
   route-policy pass-all out
  !
 !
 neighbor 1009:a01:1::2
  remote-as 6500
  address-family ipv6 unicast
   route-policy pass-all in
   route-policy pass-all out
  !
 !
!

RP/0/RP0/CPU0:ott-ss-dt-01-uut#
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.