Guest

Preview Tool

Cisco Bug: CSCur09444 - N9k : Order of commands in SVI running-config different

Last Modified

Apr 28, 2017

Products (7)

  • Cisco Nexus 9000 Series Switches
  • Cisco Nexus 9516 Switch
  • Cisco Nexus 9396PX Switch
  • Cisco Nexus 9504 Switch
  • Cisco Nexus 3164Q Switch
  • Cisco Nexus 9508 Switch
  • Cisco Nexus 93128TX Switch

Known Affected Releases

6.1(2)I2(2a)

Description (partial)

Symptom:
' sh run int vlan x' shows the commands in a different order every time you enter it.

interface Vlan16
  description VLAN15 UP_GLOBAL OSPF Interconnect		<==
  no shutdown							                        <==
  mac-address acac.acac.acac					        <== 
  ip address 172.30.240.29/30
  ip directed-broadcast
  ip ospf dead-interval 7
  ip ospf hello-interval 2
  no ip ospf passive-interface
  ip ospf retransmit-interval 4
  ip router ospf 1 area 1.0.0.16
  ip pim sparse-mode
  ip arp timeout 1200

OMHQ-N9500-V# sh run int vl 16

interface Vlan16
  ip address 172.30.240.29/30
  ip directed-broadcast
  ip ospf dead-interval 7
  ip ospf hello-interval 2
  no ip ospf passive-interface
  ip ospf retransmit-interval 4
  ip router ospf 1 area 1.0.0.16
  ip pim sparse-mode
  ip arp timeout 1200
  description VLAN15 UP_GLOBAL OSPF Interconnect		<==
  no shutdown							                        <==
  mac-address acac.acac.acac 					        <==

Conditions:
'feature dhcp' is enabled, the order in which the running-config for interface vlan is displayed changes.
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.