Guest

Preview Tool

Cisco Bug: CSCuq40256 - PFC not enabled despite NXOS config

Last Modified

Sep 10, 2019

Products (1)

  • Cisco Unified Computing System

Known Affected Releases

2.1(3c)A 2.1(3c)C 2.1(3e)A

Description (partial)

Symptom:
Following IOM reset we observe failed vhba communication when under load. The adapter and vmkernel logs are replete with aborts. 

The UCSM shows the IOM interface for the corresponding blade as up/active, but the PFC shows as disabled:

Show Int BR:
Eth15/1/29    1      eth  vntag  up      none                        10G(D) 1897
Eth15/1/30    1      eth  vntag  up      none                        10G(D) 1897  <--------- Up
Eth15/1/31    1      eth  vntag  up      none                        10G(D) 1897
Eth15/1/32    1      eth  vntag  up      none                        10G(D) 1897

Show int Priority-Flow-Control:

Ethernet15/1/29    Auto On  (8)       0          0
Ethernet15/1/30    Auto Off           0          0   <------- PFC Off
Ethernet15/1/31    Auto On  (8)       0          0
Ethernet15/1/32    Auto On  (8)       0          0

The configuration of the interface indicates PFC should be active:

PL20-B(nxos)# show run int eth 15/1/30 all

!Command: show running-config interface Ethernet15/1/30 all
!Time: Thu Sep 25 22:31:23 2014

version 5.0(3)N2(2.11.3c)

interface Ethernet15/1/30
  no description
  lacp port-priority 32768
  lacp rate normal
  priority-flow-control mode auto  <---- PFC set to auto
  switchport vntag max-vifs 118
  lldp transmit
  lldp receive
  no switchport block unicast
  no switchport block multicast
  no hardware multicast hw-hash
  no hardware vethernet mac filtering per-vlan
  no pinning server sticky
  cdp enable
  switchport
  switchport mode vntag
  no switchport dot1q ethertype
  no switchport priority extend
  no switchport port-security
  switchport port-security aging type absolute
  switchport port-security aging time 0
  switchport port-security maximum 1
  switchport port-security violation shutdown
  no switchport port-security mac-address sticky
  fabric-interface Eth3/7
  spanning-tree port-priority 128
  spanning-tree cost auto
  spanning-tree link-type auto
  spanning-tree port type edge
  spanning-tree bpduguard enable
  no spanning-tree bpdufilter
  speed 10000
  duplex auto
  flowcontrol receive off   
  flowcontrol send on     <----PFC send on
  link debounce
  no beacon
  snmp trap link-status
  logging event port link-status default
  logging event port trunk-status default
  mdix auto
  no shutdown lan
  load-interval counter 1 30
  load-interval counter 2 300
  no load-interval counter 3
  channel-group 1897
  no shutdown

Conditions:
Recent IOM reboot. Has been known to occur during upgrade of an IOM (typically during an Infra upgrade) or on insertion of a new IOM that requires a firmware downgrade.
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.