Guest

Preview Tool

Cisco Bug: CSCuq29719 - N3K: Cosmetic CLI Issue when Configuring PFC on Port-Channels

Last Modified

Feb 08, 2017

Products (7)

  • Cisco Nexus 3000 Series Switches
  • Cisco Nexus 3064 Switch
  • Cisco Nexus 3016 Switch
  • Cisco Nexus 3064-T Switch
  • Cisco Nexus 3048 Switch
  • Cisco Nexus 3132Q Switch
  • Cisco Nexus 3172 Switch

Known Affected Releases

6.0(2)U2(8.96) 6.0(2)U4(1)

Description (partial)

Symptom:
The PFC configuration is not reflected correctly on a port-channel interface when applying the "priority-flow-control mode on mode on | off" command.

The member interfaces will adopt the port-channel running configuration and operate as expected, but the port-channel running configuration will stay at the default value of "auto".

Conditions:
This occurs after upgrading from a  Culebra image (ie. 1F) to Fiji-9Z before configuring PFC on a port-channel.

End Result:

N3K-2# config t
N3K-2(config)# interface port 1
N3K-2(config-if)# priority-flow-control mode on 

N3K-2(config-if)# show run int port 1

!Command: show running-config interface port-channel1
!Time: Thu Aug  7 17:13:46 2014

version 6.0(2)U2(9Z)

interface port-channel1
  description INFRA:TRUNK:rr1-x3csp-int-cis-3-1b:Ethernet1/50/1-Ethernet1/50/2
  no switchport
  logging event port link-status
  speed 10000
  mtu 9100
  service-policy type qos input QOS_MARKING
  no ip redirects

N3K-2(config-if)# show run int eth 1/1-2

!Command: show running-config interface Ethernet1/1-2
!Time: Thu Aug  7 17:14:20 2014

version 6.0(2)U2(9Z)

interface Ethernet1/1
  lacp rate fast
  no switchport
  mtu 9100
  logging event port link-status
  channel-group 1 mode active
  priority-flow-control mode on

interface Ethernet1/2
  lacp rate fast
  no switchport
  mtu 9100
  logging event port link-status
  channel-group 1 mode active
  priority-flow-control mode on


N3K-2(config-if)# show run int port 1 all

!Command: show running-config interface port-channel1 all
!Time: Thu Aug  7 17:17:37 2014

version 6.0(2)U2(9Z)

interface port-channel1
  description INFRA:TRUNK:rr1-x3csp-int-cis-3-1b:Ethernet1/50/1-Ethernet1/50/2
  no switchport
  priority-flow-control mode auto
  lacp graceful-convergence
  no lacp suspend-individual
  lacp min-links 1
  lacp max-bundle 32
  no port-channel port load-defer
  lacp fast-select-hot-standby
  no switchport block unicast
  no switchport block multicast
  no hardware multicast hw-hash
  no hardware vethernet mac filtering per-vlan
  spanning-tree port-priority 128
  spanning-tree cost auto
  spanning-tree link-type auto
  spanning-tree port type normal
  no spanning-tree bpduguard
  no spanning-tree bpdufilter
  logging event port link-status
  logging event port trunk-status default
  speed 10000
  duplex full
  flowcontrol receive off
  flowcontrol send off
  no negotiate auto
  mtu 9100
  delay 1
  snmp trap link-status
  bandwidth 100000
  no bandwidth inherit
  storm-control broadcast level 100.00
  storm-control multicast level 100.00
  storm-control unicast level 100.00
  no shutdown lan
  load-interval counter 1 30
  load-interval counter 2 300
  no load-interval counter 3
  no mac-address
  medium broadcast
  service-policy type qos input QOS_MARKING
  no ip redirects
  ip address 192.168.11.2/24
  no shutdown
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.