Guest

Preview Tool

Cisco Bug: CSCuq12940 - description under "no switchport" interface lost in show run

Last Modified

Feb 01, 2018

Products (150)

  • Cisco Catalyst 3750-X Series Switches
  • Cisco IE 2000-4T-G Industrial Ethernet Switch
  • Cisco Catalyst 3560X-48T-E Switch
  • Cisco Catalyst 2960C-8TC-S Switch
  • Cisco Embedded Service 2020 CON B Switch
  • Cisco Catalyst 3560X-48U-S Switch
  • Cisco Catalyst 2960S-24PD-L Switch
  • Cisco Catalyst 2960C-12PC-L Switch
  • Cisco Catalyst 2960X-24PD-L Switch
  • Cisco Catalyst 3560X-48P-S Switch
View all products in Bug Search Tool Login Required

Known Affected Releases

15.2(2)E

Description (partial)

Symptom:
description under "no switchport" interface lost in show run after reload.but it can be seen in show startup-config after reload.

Conditions:
Switch#show run
Building configuration...
(snip)
interface GigabitEthernet2/0/1
 description CCCCCC
 no switchport
 no ip address
!
interface GigabitEthernet2/0/2
 description DDDDDD
!
(snip)

Switch#show startup-config
(snip)
interface GigabitEthernet2/0/1
 description CCCCCC
 no switchport
 no ip address
!
interface GigabitEthernet2/0/2
 description DDDDDD
!

Switch#reload
Proceed with reload? [confirm]

Switch#show run
(snip)
interface GigabitEthernet2/0/1
 no switchport
 no ip address
!
interface GigabitEthernet2/0/2
 description DDDDDD
!
(snip)

Switch#show startup-config
(snip)
interface GigabitEthernet2/0/1
 description CCCCCC
 no switchport
 no ip address
!
interface GigabitEthernet2/0/2
 description DDDDDD
!
(snip)
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.