Guest

Preview Tool

Cisco Bug: CSCuq09990 - Use new API from the licensing infra to renew our UDI

Last Modified

Jan 05, 2017

Products (1)

  • Cisco IOS XRv Router

Known Affected Releases

5.2.2.BASE

Description (partial)

Symptom:
Steps to reproduce:
1) Register XRv with the SL staging backend
2) Issue "license request new-udi" CLI
3) The following syslog shows up
%SMART_LIC-3-AUTH_RENEW_FAILED:Authorization renewal with Cisco licensing cloud failed: Response error: {"sudi":["The sudi '{\"suvi\"=>nil, \"uuid\"=>nil, \"host_identifier\"=>nil, \"udi_pid\"=>\"IOSXRV\", \"udi_serial_number\"=>\"9O4GC9Y8HSV\", \"udi_vid\"=>nil, \"mac_address\"=>nil}' is not valid for the instance '767bed1f-1abf-4cab-9772-f3bb057e61d2'."]}
4) Routers still stays in authorized state but SL backend does not reflect the new UDI
5) if the router is reloaded, it goes back to "Eval Period" and the following syslog shows up on startup

RP/0/0/CPU0:Jul 25 04:24:25.245 : licmgr[295]: %LICENSE-LICMGR-3-CHASSIS_MISMATCH : License database and this chassis do not match. If licenses were installed, restore from a backup or contact Cisco TAC.

After reload:
RP/0/0/CPU0:jbert-sl-07242014-newimage#admin show license status 
Fri Jul 25 04:28:00.950 UTC
Compliance Status: Eval period
 
RP/0/0/CPU0:jbert-sl-07242014-newimage#admin show license register-status 
Fri Jul 25 04:28:06.870 UTC
    Registration Status: Not Registered
        Last Response Time: Mon Apr 19 2027 04:47:23 UTC
        Last Response Message: Certificate validation failed
RP/0/0/CPU0:jbert-sl-07242014-newimage#

Conditions:
Steps to reproduce:
1) Register XRv with the SL staging backend
2) Issue "license request new-udi" CLI
3) The following syslog shows up
%SMART_LIC-3-AUTH_RENEW_FAILED:Authorization renewal with Cisco licensing cloud failed: Response error: {"sudi":["The sudi '{\"suvi\"=>nil, \"uuid\"=>nil, \"host_identifier\"=>nil, \"udi_pid\"=>\"IOSXRV\", \"udi_serial_number\"=>\"9O4GC9Y8HSV\", \"udi_vid\"=>nil, \"mac_address\"=>nil}' is not valid for the instance '767bed1f-1abf-4cab-9772-f3bb057e61d2'."]}
4) Routers still stays in authorized state but SL backend does not reflect the new UDI
5) if the router is reloaded, it goes back to "Eval Period" and the following syslog shows up on startup

RP/0/0/CPU0:Jul 25 04:24:25.245 : licmgr[295]: %LICENSE-LICMGR-3-CHASSIS_MISMATCH : License database and this chassis do not match. If licenses were installed, restore from a backup or contact Cisco TAC.

After reload:
RP/0/0/CPU0:jbert-sl-07242014-newimage#admin show license status 
Fri Jul 25 04:28:00.950 UTC
Compliance Status: Eval period
 
RP/0/0/CPU0:jbert-sl-07242014-newimage#admin show license register-status 
Fri Jul 25 04:28:06.870 UTC
    Registration Status: Not Registered
        Last Response Time: Mon Apr 19 2027 04:47:23 UTC
        Last Response Message: Certificate validation failed
RP/0/0/CPU0:jbert-sl-07242014-newimage#
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.