Guest

Preview Tool

Cisco Bug: CSCup64413 - CTIPort returns IpAddrMode as IPv4 when created with default mode

Last Modified

Aug 27, 2020

Products (1)

  • Cisco Unified Communications Manager (CallManager)

Known Affected Releases

10.5(1.98300.9)

Description (partial)

Symptom:
CTI Ports/CTI route points are not displaying IPv6 address though we send IPv4 and IPv6 address during registration. IPAddrMode for device not updated correctly when 'Common Device Config' configured as "NONE".

This introduces the change in behavior:

Old behavior (before CSCup64413) :
CUCM sends configured IP address mode as 'IPv4' if no "Common Device Config" is associated with a device.

New behavior (with CSCup64413):
CUCM sends configured IP address mode as 'IPv4 and IPv6' if no "Common Device Config" is associated with a device.


In CSCus44723, this behaviour is configurable:

'IP Addressing mode for Device' Service parameter determines the configured IP Addressing mode for a device which will be exposed to CTI applications when no Common Device Configuration is applied to that device. The default setting is "IPv4 and IPv6". If any CTI application expects CTI to send "IPv4 only" as the configured IP addressing mode, set the parameter value to "IPv4 only". When a Common Device Configuration is applied to a device, the IP Addressing mode selected there will take precedence and override this parameter value.

Conditions:
-device has no 'Common Device Config' associated, default value for IP address mode is taken

Related Community Discussions

CTI route point and CTI ports not registering - UCCX 10.5 and CUCM 10.5 - PARTIAL SERVICE
I'm trying to integrate CUCM 10.5 and UCCX 10.5. For some reason CTI route point and CTI ports are not registering on the CUCM and the status of the UCCX is "PARTIAL SERVICE". On the UCCX Cisco Unified CCX Engine is in status "PARTIAL SERVICE" and the Unified CM Telephony Subsystem shows status "OUT OF SERVICE". I tried with completely new installation of UCCX twice and got the same result twice.   But when I tried integrating UCCX 10 with the same CUCM 10.5 from above everything works fine and all ...
Latest activity: Feb 15, 2016
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.