Guest

Preview Tool

Cisco Bug: CSCup59531 - ipv6 address FE80::1 link-local add dynamically in running configuration

Last Modified

Dec 03, 2019

Products (84)

  • Cisco IOS
  • Cisco 881SRSTW Integrated Services Router
  • Cisco C892FSP Integrated Services Router
  • Cisco C897VA Integrated Services Router
  • Cisco 888W Integrated Services Router
  • Cisco 861W Integrated Services Router
  • Cisco 886VA-CUBE Integrated Services Router
  • Cisco 1905 Serial Integrated Services Router
  • Cisco 812 CiFi Integrated Services Router
  • Cisco 819 Hardened Integrated Services Router
View all products in Bug Search Tool Login Required

Known Affected Releases

15.4(2)T1

Description (partial)

Symptom:
Topology :

CPE-------BRAS-----Radius

PPP negotiation takes place between CPE and BRAS.
Radius is configured to push Ipv6 link local address dynamically after successful PPP negotiation
After successful PPP negotiation, dialer configuration gets changed automatically to reflect the dynamically received IPv6 address in running configuration.

<Output before PPP negotiation>
########################

PD-Test#show run | section Dialer11
interface Dialer11
description PPPoE
mtu 1492
ip address negotiated
no ip proxy-arp
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 11
dialer idle-timeout 0
dialer persistent
dialer-group 11
ipv6 address autoconfig
ipv6 enable
ipv6 dhcp client pd pfx_di11
ppp authentication pap callin
ppp pap sent-username XXXX password XXXX
ppp ipcp dns request
ppp ipcp mask request
no cdp enable
ip route 0.0.0.0 0.0.0.0 Dialer11
ipv6 route ::/0 Dialer11


<Output after PPP negotiation>
######################
PD-Test#show run | section Dialer11
interface Dialer11
description PPPoE
mtu 1492
ip address negotiated
no ip proxy-arp
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 11
dialer idle-timeout 0
dialer persistent
dialer-group 11
ipv6 address FE80::1 link-local                       ----------- Added automatically
ipv6 address autoconfig
ipv6 enable
ipv6 dhcp client pd pfx_di11
ppp authentication pap callin
ppp pap sent-username XXXX password XXXX
ppp ipcp dns request
ppp ipcp mask request
no cdp enable
ip route 0.0.0.0 0.0.0.0 Dialer11
ipv6 route ::/0 Dialer11

Conditions:
it will be added automatically only if it is not configured on dialer interface and it is being pushed from Radius server into the network.
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.