Guest

Preview Tool

Cisco Bug: CSCup55985 - Notifications Not Sent With HA When VipIsUp state is false

Last Modified

Oct 16, 2015

Products (1)

  • Cisco Webex Meetings Server

Known Affected Releases

2.0.1.302 2.5.0.1388

Description (partial)

Symptom:
- The admin user does not receive email after the customized log is generated and they have to login to CLI to copy the log from /triage/download/log/xxxxx everytime
-The restart of services or reboot fixes the issue but it re-occurs again

On the analysis of the problem, the mechanism that helps determine the operating/active VM that should be sending notification is a check for the VIP.  Email is not sent because isVipUp() returns false. This method counts all interfaces on machine, and only if it finds more than one, email will be sent. Here we have situation where webadmin is active on primary but eth1 is on secondary admin. Therefore isVipUp() on primary counts only eth0 and never sends email.

Conditions:
According to logserver.log on primary admin VM, user landed on primary admin VM and submitted a request for infocap, but there is a sync error to HA admin(10.77.252.54), and finally didn't send out infocap mail because of primary admin VM's vipIsUp is false. The same mechanism we also use for which VM is supposed to send the notification in general. We believe the problem existed in v1.5 also.
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.