Guest

Preview Tool

Cisco Bug: CSCuo19731 - RISE-NAM service shutdown loses data port configuration

Last Modified

Feb 03, 2017

Products (1)

  • Cisco Nexus 7000 Series Switches

Known Affected Releases

6.2(8)S15

Description (partial)

Symptom:
RISE-NAM service shutdown causes the data port config to go away, unshut will not bring back the config. Shutdown is working as removing service

Conditions:
RISE-n77# sh rise 
Name            Slot Vdc Rise-Ip         State        Interface
                  Id  Id                                       
--------------- ---- --- --------------- ------------ ----------------
RISE-NAM-77     300  1   172.23.228.125  active       Eth1/39        
RISE-n77# sh run int e1/41
!
interface Ethernet1/41  <===== Data port is configured
  switchport
  switchport mode trunk
  switchport monitor
  no shutdown

RISE-n77# conf t
RISE-n77(config)# service type rise name RISE-NAM-77 mode direct
RISE-n77(config-rise)# shut
RISE-n77(config-rise)# 
RISE-n77(config-rise)# 2014 Apr  8 22:31:13 RISE-n77 %$ VDC-1 %$ %ISCM-2-RISE_SERVICE_INACTIVE: service 'RISE-NAM-77' (slot id 300) became inactive.

RISE-n77(config-rise)# 
RISE-n77(config-rise)# sh run int e1/41
!
interface Ethernet1/41  <======= Data port config is gone after service is shut
  no shutdown
RISE-n77(config-rise)# no shut
RISE-n77(config-rise)# service type rise name RISE-NAM-77 mode direct2014 Apr  8 22:39:09 RISE-n77 %$ VDC-1 %$ %ISCM-2-RISE_SERVICE_ACTIVE: service 'RISE-NAM-77' (slot id 300) became active.
RISE-n77(config-rise)# 
RISE-n77(config-rise)# 
RISE-n77(config-rise)# 
RISE-n77(config-rise)# sh rise 
Name            Slot Vdc Rise-Ip         State        Interface
                  Id  Id                                       
--------------- ---- --- --------------- ------------ ----------------
RISE-NAM-77     300  1   172.23.228.125  active       Eth1/39        
RISE-n77(config-rise)# sh running-config int e1/41
!
interface Ethernet1/41 <==== not restored after unshut
  no shutdown

RISE-n77(config-rise)#
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.