Guest

Preview Tool

Cisco Bug: CSCuo13937 - PVLAN:"Failed to configure hardware" on configuring vpc secondary

Last Modified

Jan 31, 2017

Products (1)

  • Cisco Nexus 7000 Series Switches

Known Affected Releases

6.2(8)S13

Description (partial)

Symptom:
1. In a VPC setup as 

n7k-1===n7k-2
  \              /
   \   po3   /
       c4k

VPC is configured in private-vlan host mode and vpc is up

2. Now if one of the VPC legs is configured with the following configuration, PVLAN throws an error as follows:

switch-two(config-if)# switchport mode private-vlan promiscuous
switch-two(config-if)# switchport private-vlan mapping 2 3
ERROR: Port-Channel 10 : Failed to configure hardware

3. The CLI is rejected for port-channel, but the member ports get the correct configuration. Also, the programming and PVLAN state is not affected and it is still programmed correctly.
Member port shows the correct running config:
switch-two(config-if)# ^C
switch-two(config-if)# show running-config interface e7/1

!Command: show running-config interface Ethernet7/1
!Time: Fri Apr 18 00:43:00 2014

version 6.2(8)

interface Ethernet7/1
  switchport
  switchport mode private-vlan promiscuous
  switchport private-vlan host-association 2 3
  switchport private-vlan mapping 2 3
  channel-group 10
  no shutdown

Conditions:
1. This happens when one of the VPC legs is still in some other mode that promiscuous, and the configuration is applied on the other VPC leg to make the mode promiscuous
2. The actual error is seen when the promiscuous mapping is configured
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.