Guest

Preview Tool

Cisco Bug: CSCul85304 - UDI Compliant SFP not showing up correctly in show inventory

Last Modified

Feb 19, 2018

Products (1)

  • Cisco 2900 Series Integrated Services Routers

Known Affected Releases

15.1(4)M6.10 15.3(3)M 15.4(1.15)T

Description (partial)

Symptom:
UDI compliant SFPs are not showing the correct PID in the 'show inventory' output after inserted into a HWIC-1GE-SFP or an EHWIC-1GE-SFP-CU  

################################
FROM SHOW INVENTORY OUTPUT
################################
NAME: "1000BASE-LX SFP", DESCR: "1000BASE-LX SFP"
PID: SCP6J44-C1-BMH    , VID: A  , SN: XXXXXXXXXXX

NAME: "1000BASE-SX SFP", DESCR: "1000BASE-SX SFP"
PID: FTLF8519P3BNL-CS  , VID: A  , SN: XXXXXXXXXXX


Here we see UDI SFPs are showing something like FTLF8519P2BCL-CS under the PID which seems like the manufacturer's data.  For UDI compliant SFPs, they need to show the actual PID which is GLC-LH-SMD and GLC-SX-MMD in this case.

Conditions:
This was seen after inserting the SFPs into a HWIC-1GE-SFP on a 2921. The issue is likely the same on any ISR-G2. I have also noticed this issue on a 2811 which is an ISR-G1
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.