Guest

Preview Tool

Cisco Bug: CSCul84648 - Inerited port-profiles are expanded in "show run int eth x/y" output

Last Modified

Feb 15, 2018

Products (1)

  • Cisco Nexus 7000 Series Switches

Known Affected Releases

6.2(2)S20

Description (partial)

Symptom:
Port profile config is showing under interfaces that are inheriting, but only when the # of switchport trunk allowed vlan' s has alot of VLAN's. When I just allow 5-6 VLAN's the issue is not present, and the interfaces that inerit are not showing the full config.

Conditions:
++working condition:
interface Ethernet3/1
  inherit port-profile HP-VC-DATA
  speed 1000
  no shutdown

SJCK-302.08.12-N7K-2(config-if)# sh port-profile 

port-profile HP-VC-DATA
 type: Ethernet
 description: 
 status: enabled
 max-ports: 512
 inherit: 
 config attributes:
  switchport
  switchport mode trunk
  spanning-tree port type edge trunk
  mtu 9216
  storm-control broadcast level 0.10
  switchport trunk allowed vlan 1-2, 10, 20, 30
  no shutdown
 evaluated config attributes:
  switchport
  switchport mode trunk
  spanning-tree port type edge trunk
  mtu 9216
  storm-control broadcast level 0.10
  switchport trunk allowed vlan 1-2, 10, 20, 30
  no shutdown
 assigned interfaces:
  Ethernet3/1
  Ethernet3/2

!! Broken condition
port-profile HP-VC-DATA
 type: Ethernet
 description: 
 status: enabled
 max-ports: 512
 inherit: 
 config attributes:
  switchport
  switchport mode trunk
  spanning-tree port type edge trunk
  mtu 9216
  storm-control broadcast level 0.10
  switchport trunk allowed vlan 1-13, 31-38, 52-60, 63-66, 78-93, 101-111, 114-1
16, 119, 230, 250-273
  no shutdown
 evaluated config attributes:
  switchport
  switchport mode trunk
  spanning-tree port type edge trunk
  mtu 9216
  storm-control broadcast level 0.10
  switchport trunk allowed vlan 1-13, 31-38, 52-60, 63-66, 78-93, 101-111, 114-1
16, 119, 230, 250-273
  no shutdown
 assigned interfaces:
  Ethernet3/1
  Ethernet3/2



interface Ethernet3/1
  inherit port-profile HP-VC-DATA
  switchport trunk allowed vlan 1-13, 31-38, 52-60, 63-66, 78-93, 101-111
  switchport trunk allowed vlan add 114-116, 119, 230, 250-273
  speed 1000
  no shutdown
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.