Guest

Preview Tool

Cisco Bug: CSCul56620 - CDP breaks on On L3 side in L3 -> L2 set up on F2/M1- 6.1(3)

Last Modified

Jan 03, 2019

Products (5)

  • Cisco Nexus 7000 Series Switches
  • Cisco Nexus 7000 10-Slot Switch
  • Cisco Nexus 7000 4-Slot Switch
  • Cisco Nexus 7000 18-Slot Switch
  • Cisco Nexus 7000 9-Slot Switch

Known Affected Releases

6.1(3)

Description (partial)

Symptom:
CDP doesn't work on L3 side When F2 or M1 line card are configured in L3 >> L2  fashion

** L3 side

sh cdp neighbors 
Capability Codes: R - Router, T - Trans-Bridge, B - Source-Route-Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater,
                  V - VoIP-Phone, D - Remotely-Managed-Device,
                  s - Supports-STP-Dispute

Device-ID          Local Intrfce  Hldtme Capability  Platform      Port ID


Note:- Initially when you bring the connection for the first time or perform shut/no shut, CDP will populate, but it will timeout after 180 sec

** L2 side

sh cdp neighbors 
Capability Codes: R - Router, T - Trans-Bridge, B - Source-Route-Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater,
                  V - VoIP-Phone, D - Remotely-Managed-Device,
                  s - Supports-STP-Dispute

Device-ID          Local Intrfce  Hldtme Capability  Platform      Port ID
TEST_N7K4_Default
                    Eth4/1         133    R S s     N7K-C7009     Eth4/25       
TEST_N7K4_Default
                    Eth4/5         130    R S s     N7K-C7009     Eth4/38

Conditions:
### L2 side configuration 

interface port-channel300
  switchport
  switchport mode trunk
  switchport trunk native vlan 300
  switchport trunk allowed vlan 300

interface Ethernet4/1
  switchport
  switchport mode trunk
  switchport trunk native vlan 300
  switchport trunk allowed vlan 300
  channel-group 300 mode active
  no shutdown

interface Ethernet4/5
  switchport
  switchport mode trunk
  switchport trunk native vlan 300
  switchport trunk allowed vlan 300
  channel-group 300 mode active
  no shutdown
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.