Guest

Preview Tool

Cisco Bug: CSCui96329 - PVLAN config inheritance incomplete

Last Modified

Feb 22, 2014

Products (2)

  • Cisco Nexus 1000V Switch for VMware vSphere
  • Cisco Nexus 1000V Switch

Known Affected Releases

4.2(1)SV2(1.1)

Description (partial)

Symptom:
Seeing errors like the following when adding a secondary VLAN to the private VLAN mapping statement in an existing port-profile:

ERROR: Ethernet1/1 : Primary vlan is not mapped on port(s)			
       Ethernet10/5 : Primary vlan is not mapped on port(s)
       Ethernet11/5 : Primary vlan is not mapped on port(s)
       Ethernet12/5 : Primary vlan is not mapped on port(s)
       Ethernet3/5 : Primary vlan is not mapped on port(s)
       Ethernet4/5 : Primary vlan is not mapped on port(s)
       Ethernet5/5 : Primary vlan is not mapped on port(s)
       Ethernet6/6 : Primary vlan is not mapped on port(s)
       Ethernet7/6 : Primary vlan is not mapped on port(s)
       Ethernet8/5 : Primary vlan is not mapped on port(s)
       Ethernet9/5 : Primary vlan is not mapped on port(s) 

In the above, the existing port-profile is:

port-profile type ethernet dataplane-uplink
  vmware port-group
  inherit port-profile dataplane-pvlan
  switchport mode trunk
  switchport trunk allowed vlan 1-306,309-3967,4048-4093
  channel-group auto mode on mac-pinning
  no shutdown
  system vlan 301-306,310-325,327-330,402-409,412-414,416-422
  state enabled

port-profile type ethernet dataplane-pvlan
  switchport mode trunk
  switchport private-vlan mapping trunk 303 315-316,319,321,323,325,327
  switchport private-vlan mapping trunk 303 add 329
  switchport private-vlan mapping trunk 304 317-318,320,322,324,328,337
  switchport private-vlan mapping trunk 305 311-314
  switchport private-vlan mapping trunk 306 310
  switchport private-vlan trunk allowed vlan 1-3967,4048-4093
  switchport private-vlan mapping trunk 403 405-406,409,412,414,416,418-420
  switchport private-vlan mapping trunk 403 add 422,424
  switchport private-vlan mapping trunk 404 407-408,413,417,421
  no shutdown
  state enabled

Tried to do 'switchport private-vlan mapping trunk 303 add 339' under 'port-profile type ethernet dataplane-pvlan'

Conditions:
- In the above example, it was seen when inherting a child port-profile ('dataplane-uplink' - child ; 'dataplane-pvlan' - parent). At this point, it is not clear if it can happen even without hierarchical port-profiles
- 'show running-config expand-port-profile' would show that only a part of the configuration to have been inherited correctly:

interface port-channel5
   switchport mode trunk
   vem 3
   switchport trunk allowed vlan 1-306,309-3967,4048-4093
   switchport private-vlan trunk allowed vlan 1-3967,4048-4093
   switchport private-vlan mapping trunk 304 317-318,320,322,324,328,337
   switchport private-vlan mapping trunk 403 405-406,409,412,414,416,418-420,422,424
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.