Guest

Preview Tool

Cisco Bug: CSCte28848 - no ifindex created for the 'interface vlan <vlan_id>'

Last Modified

Aug 27, 2015

Products (3)

  • Cisco Nexus 5000 Series Switches
  • Cisco Nexus 5020 Switch
  • Cisco Nexus 5010 Switch

Known Affected Releases

4.1(3)N2(1a)

Description (partial)

Symptom:
when the vlan interface is created, there is no interface instantiated:
Excerpt from show running-config:
interface Vlan1

interface Vlan80
  no shutdown
  ip address 10.10.105.90/24

interface port-channel2
  switchport access vlan 5
  speed 10000

interface port-channel4

interface Ethernet1/1
  speed 1000

interface Ethernet1/2
  switchport access vlan 5
  channel-group 2 mode active

interface Ethernet1/3
  switchport access vlan 5
  channel-group 2 mode active

When attempting to view it in nx-os we do not see interface vlan 1,80:
F-5020-2(config-if)# show interface snmp-ifindex 

--------------------------------------------------------------------------------
Port             IFMIB Ifindex (hex)
--------------------------------------------------------------------------------
Eth1/1          436207616  (0x1a000000)
Eth1/2          436211712  (0x1a001000)
Eth1/3          436215808  (0x1a002000)
Eth1/4          436219904  (0x1a003000)
Eth1/5          436224000  (0x1a004000)
Eth1/6          436228096  (0x1a005000)
Eth1/7          436232192  (0x1a006000)
Eth1/8          436236288  (0x1a007000)
Eth1/9          436240384  (0x1a008000)
Eth1/10         436244480  (0x1a009000)
Eth1/11         436248576  (0x1a00a000)
Eth1/12         436252672  (0x1a00b000)
Eth1/13         436256768  (0x1a00c000)
Eth1/14         436260864  (0x1a00d000)
Eth1/15         436264960  (0x1a00e000)
Eth1/16         436269056  (0x1a00f000)
Eth1/17         436273152  (0x1a010000)
Eth1/18         436277248  (0x1a011000)
Eth1/19         436281344  (0x1a012000)
Eth1/20         436285440  (0x1a013000)
Eth1/21         436289536  (0x1a014000)
Eth1/22         436293632  (0x1a015000)
Eth1/23         436297728  (0x1a016000)
Eth1/24         436301824  (0x1a017000)
Eth1/25         436305920  (0x1a018000)
Eth1/26         436310016  (0x1a019000)
Eth1/27         436314112  (0x1a01a000)
Eth1/28         436318208  (0x1a01b000)
Eth1/29         436322304  (0x1a01c000)
Eth1/30         436326400  (0x1a01d000)
Eth1/31         436330496  (0x1a01e000)
Eth1/32         436334592  (0x1a01f000)
Eth1/33         436338688  (0x1a020000)
Eth1/34         436342784  (0x1a021000)
Eth1/35         436346880  (0x1a022000)
Eth1/36         436350976  (0x1a023000)
Eth1/37         436355072  (0x1a024000)
Eth1/38         436359168  (0x1a025000)
Eth1/39         436363264  (0x1a026000)
Eth1/40         436367360  (0x1a027000)
Eth2/1          436731904  (0x1a080000)
Eth2/2          436736000  (0x1a081000)
Eth2/3          436740096  (0x1a082000)
Eth2/4          436744192  (0x1a083000)
Eth2/5          436748288  (0x1a084000)
Eth2/6          436752384  (0x1a085000)
Eth3/1          437256192  (0x1a100000)
Eth3/2          437260288  (0x1a101000)
Eth3/3          437264384  (0x1a102000)
Eth3/4          437268480  (0x1a103000)
Po2             369098753  (0x16000001)
Po4             369098755  (0x16000003)

F-5020-2(config-if)# 

from an snmp server we do not get it either:
[root@rtp-repo ~]# snmpwalk -c private -v1 10.10.151.64 .1.3.6.1.2.1.2.2.1.2
IF-MIB::ifDescr.83886080 = STRING: mgmt0
IF-MIB::ifDescr.369098753 = STRING: port-channel2
IF-MIB::ifDescr.369098755 = STRING: port-channel4
IF-MIB::ifDescr.436207616 = STRING: Ethernet1/1
IF-MIB::ifDescr.436211712 = STRING: Ethernet1/2
IF-MIB::ifDescr.436215808 = STRING: Ethernet1/3
IF-MIB::ifDescr.436219904 = STRING: Ethernet1/4
IF-MIB::ifDescr.436224000 = STRING: Ethernet1/5
IF-MIB::ifDescr.436228096 = STRING: Ethernet1/6
IF-MIB::ifDescr.436232192 = STRING: Ethernet1/7
IF-MIB::ifDescr.436236288 = STRING: Ethernet1/8
IF-MIB::ifDescr.436240384 = STRING: Ethernet1/9
IF-MIB::ifDescr.436244480 = STRING: Ethernet1/10
IF-MIB::ifDescr.436248576 = STRING: Ethernet1/11
IF-MIB::ifDescr.436252672 = STRING: Ethernet1/12
IF-MIB::ifDescr.436256768 = STRING: Ethernet1/13
IF-MIB::ifDescr.436260864 = STRING: Ethernet1/14
IF-MIB::ifDescr.436264960 = STRING: Ethernet1/15
IF-MIB::ifDescr.436269056 = STRING: Ethernet1/16
IF-MIB::ifDescr.436273152 = STRING: Ethernet1/17
IF-MIB::ifDescr.436277248 = STRING: Ethernet1/18
IF-MIB::ifDescr.436281344 = STRING: Ethernet1/19
IF-MIB::ifDescr.436285440 = STRING: Ethernet1/20
IF-MIB::ifDescr.436289536 = STRING: Ethernet1/21
IF-MIB::ifDescr.436293632 = STRING: Ethernet1/22
IF-MIB::ifDescr.436297728 = STRING: Ethernet1/23
IF-MIB::ifDescr.436301824 = STRING: Ethernet1/24
IF-MIB::ifDescr.436305920 = STRING: Ethernet1/25
IF-MIB::ifDescr.436310016 = STRING: Ethernet1/26
IF-MIB::ifDescr.436314112 = STRING: Ethernet1/27
IF-MIB::ifDescr.436318208 = STRING: Ethernet1/28
IF-MIB::ifDescr.436322304 = STRING: Ethernet1/29
IF-MIB::ifDescr.436326400 = STRING: Ethernet1/30
IF-MIB::ifDescr.436330496 = STRING: Ethernet1/31
IF-MIB::ifDescr.436334592 = STRING: Ethernet1/32
IF-MIB::ifDescr.436338688 = STRING: Ethernet1/33
IF-MIB::ifDescr.436342784 = STRING: Ethernet1/34
IF-MIB::ifDescr.436346880 = STRING: Ethernet1/35
IF-MIB::ifDescr.436350976 = STRING: Ethernet1/36
IF-MIB::ifDescr.436355072 = STRING: Ethernet1/37
IF-MIB::ifDescr.436359168 = STRING: Ethernet1/38
IF-MIB::ifDescr.436363264 = STRING: Ethernet1/39
IF-MIB::ifDescr.436367360 = STRING: Ethernet1/40
IF-MIB::ifDescr.436731904 = STRING: Ethernet2/1
IF-MIB::ifDescr.436736000 = STRING: Ethernet2/2
IF-MIB::ifDescr.436740096 = STRING: Ethernet2/3
IF-MIB::ifDescr.436744192 = STRING: Ethernet2/4
IF-MIB::ifDescr.436748288 = STRING: Ethernet2/5
IF-MIB::ifDescr.436752384 = STRING: Ethernet2/6
IF-MIB::ifDescr.437256192 = STRING: Ethernet3/1
IF-MIB::ifDescr.437260288 = STRING: Ethernet3/2
IF-MIB::ifDescr.437264384 = STRING: Ethernet3/3
IF-MIB::ifDescr.437268480 = STRING: Ethernet3/4

[root@rtp-repo ~]# 

there is no interface vlan 1 or 80.
Conditions:
happens all the time
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.