Preview Tool

Cisco Bug: CSCtd89026 - SecureCRT 4.09 fails to connect, post CSCin90961

Last Modified

Sep 30, 2015

Products (1)

  • Cisco IOS

Known Affected Releases


Description (partial)

Client connections initiated from SecureCRT 4.09 to IOS SSH servers running SSH version 2 are failing due to invalid modulus value presented by client

The issue has been duplicated on 12.4(24)T1 and 15.0(1)XA and appears to be happening in all IOS releases greater than 12.4(15)T9.  The issue happens when running SecureCRT as the client and SSH version 2 on the IOS server.

SSH Debugs in IOS show the following message:
Dec  3 10:55:22.494 EST: SSH2 0: Range sent by client is - 1024 < 2046 <2046
Dec  3 10:55:22.494 EST: SSH2 0:  Invalid modulus length
Bug details contain sensitive information and therefore require a account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.