Guest

Preview Tool

Cisco Bug: CSCtd73272 - Should not allow attaching non-existance policy-map to port-profile

Last Modified

Jun 16, 2010

Products (1)

  • Cisco Nexus 1000V Switch for VMware vSphere

Known Affected Releases

4.0(4)SV1(2)

Description (partial)

Symptom:
N1k should not allow attaching non-existence policy-map to port-profile:
n1k# sh port-profile name dummy1
port-profile dummy1
  description:
  type: vethernet
  status: enabled
  capability l3control: no
  pinning control-vlan: -
  pinning packet-vlan: -
  system vlans: none
  port-group: dummy1
  max ports: 256
  inherit:
  config attributes:
    switchport mode access
    switchport access vlan 1108
    no shutdown
  evaluated config attributes:
    switchport mode access
    switchport access vlan 1108
    no shutdown
  assigned interfaces:
    Vethernet26
n1k#
n1k# sh policy-map dummy1
ERROR: Policy map does not exist

n1k# conf t
n1k(config)# port-profile dummy1
n1k(config-port-prof)# service-policy input dummy1
n1k(config-port-prof)# 2009 Dec  9 14:37:46.233 n1k %IPQOSMGR-3-QOSMGR_CONFIG_ERROR: Configuration error: Failed to set service policy on interface Vethernet26 from port profile, error: Invalid Command(0x415e0011) .

n1k(config-port-prof)# no service-policy input dummy1
n1k(config-port-prof)# 2009 Dec  9 14:38:06.796 n1k %IPQOSMGR-3-QOSMGR_CONFIG_ERROR: Configuration error: Failed to set service policy on interface Vethernet26 from port profile, error: Invalid Command(0x415e0011) .

N1k does not allow attachment of non-existence policy-map to interface:
n1k(config)# int vethernet 26
n1k(config-if)# service-policy input dummy1
ERROR: policy-map dummy1 (type: qos) not configured

The same check should be done when attaching policy-map to port-profile.

N1k performs proper check when attempt to remove policy-map that is in used:
n1k(config)# policy-map dummy1
n1k(config-pmap-qos)# class class-default
n1k(config-pmap-c-qos)# set cos 7
n1k(config-pmap-c-qos)# port-profile dummy1
n1k(config-port-prof)# service-policy input dummy1
n1k(config-port-prof)# exit
n1k(config)# no policy-map type qos dummy1
ERROR: Policy-map is being referenced in service policies[1], remove the reference(s) and try again

Conditions:
Attaching non existence policy-map to port-profile.
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.