Preview Tool

Cisco Bug: CSCta48690 - Comment line not restored from interface preconfigure to active

Last Modified

Jan 12, 2017

Products (1)

  • Cisco Carrier Routing System

Known Affected Releases


Description (partial)


At OIR Line Card insertion the 
<CmdBold>interface preconfigure<noCmdBold><CmdArg>r/s/m/i<noCmdArg> config 
is moved to <CmdBold>interface<noCmdBold><CmdArg>r/s/m/i<noCmdArg> (active) 
config. If the interface pre-config contains a comment line (with a leading 
exclamation mark "!") this line is not restored in the active interface 


In IOS-XR it is possible to pre-configure interfaces even if the physical
media is not present. 
If a new LC is inserted or activated with a PLIM/SPA of the corresponding 
media type the interface pre-config is moved to an active interface config.
The problem is seen if the interface pre-config contains a comment line.
A similar issue can be observed in the oposite direction whe there is an
active interface configuration, there was never a corresconding pre-config
and the LC/PLIM/SPA is removed. If the active interface config has a
comment line it is not restored when it moves to pre-config.
Bug details contain sensitive information and therefore require a account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.