Guest

Preview Tool

Cisco Bug: CSCsg39936 - Pix/ASA: Disabling pim on subinterface causes other interface mcast fail

Last Modified

Nov 09, 2016

Products (1)

  • Cisco ASA 5500-X Series Firewalls

Known Affected Releases

7.0 7.2(1)

Description (partial)

Symptom:
If two subinterfaces are defined using the same physical interface, and 
pim is disabled on one of the subinterfaces, this might  cause 
 multicast to fail on the other subinterfaces attached to that same 
physical interface.

Example:

# If multicast, and two sub-interfaces are configured like below:

!
multicast-routing
!
 interface Ethernet0/0.10
   vlan 10
   nameif dmz1
   security-level 80
   ip address 10.1.1.1 255.255.255.0
 !
 interface Ethernet0/0.100
   vlan 100
   nameif 100
   security-level 60
   ip address 10.4.4.4 255.255.255.0
 !

# Disabling PIM on one of the interfaces (like below), will cause multicast traffic on the other 
subinterface to fail
ciscoasa# conf t
 ciscoasa(config)# int E0/0.100
 ciscoasa(config-subif)# no pim
 ciscoasa(config-subif)# end

Conditions:
More than one subinterface must be configured for a single physical interface, and 
multicast routing must be enabled.
Bug details contain sensitive information and therefore require a Cisco.com account to be viewed.

Bug Details Include

  • Full Description (including symptoms, conditions and workarounds)
  • Status
  • Severity
  • Known Fixed Releases
  • Related Community Discussions
  • Number of Related Support Cases
Bug information is viewable for customers and partners who have a service contract. Registered users can view up to 200 bugs per month without a service contract.